Skip to content

Commit

Permalink
app-misc/mc: bump up to 4.8.21
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.38, Repoman-2.3.9
  • Loading branch information
Sergei Trofimovich committed Jun 3, 2018
1 parent d66c707 commit 7154695
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/mc/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST mc-4.8.15.tar.xz 2304812 BLAKE2B 33d8055316b4ae9d8b2385c3a439339fa635e3f145
DIST mc-4.8.18.tar.xz 2462080 BLAKE2B 10cd93cea439290922c0dc19e85b6c9456ce4266f35eeecbf2f40d99e3aae64465d9c427fa01d7d2c542e8bae9d2926e8ce42766c4c1656373905c3d871d71c0 SHA512 edd81f6ab50ca7bb3582064f6722e490d33ae9dfbef3835e26206089d3898420968da394780c594083fa17c01a85cda9068d9931199b8319bf6361f90e900eb8
DIST mc-4.8.19.tar.xz 2521808 BLAKE2B b4712d833e8562b0f760b4558533ac338cf8875dc9034cbec2160444bbe3e9f4dc7fcec16835cabdd5cde6b02a7020162b3cd1693863775ee3494c9b4659a7aa SHA512 aec49f0da1fc69099ce9b0f71926d1e9ee6df0be12f53da94a8f5f4266612515031cd02f328a458bf78260c5efb1c8ca2c34c89e20a77567c8b987e43d446531
DIST mc-4.8.20.tar.xz 2529580 BLAKE2B 14e575b650d28e0dcaa8ef0dc0b8e9bbf3e840ddc3d34d20518d28a6b253a8769c041c29ef7136c5fb72bd6130b0fc6c367dab8e44e040ef6dfd5406c364b86c SHA512 c2460561ae94bed75b1ed12f5c8039c9f8ace4c06987c57d07b8399c4e01c5a6c57851fddb3e918a4541ade089c89e8526078572a09580ccd0ae95344e3c1138
DIST mc-4.8.21.tar.xz 2528292 BLAKE2B 0cbebcd2284f9ed9687022280aa1ba9e4a5960c6f1de27e5f4bab1b9bf205077dec2851e47b787aa6aec9cac28d467bf58ee2647a592e194ab3bfc63138b373f SHA512 db1a252744b47ebf5339ad204d8b69cb914f25ade7fe5aae2650c4abb57478715d3b7b3a24f4460adfb9fbdc928e8728b369b4f1709215e5e9af3d430fce6acf
93 changes: 93 additions & 0 deletions app-misc/mc/mc-4.8.21.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit flag-o-matic

MY_P=${P/_/-}

DESCRIPTION="GNU Midnight Commander is a text based file manager"
HOMEPAGE="https://www.midnight-commander.org"
SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE="+edit gpm mclib nls samba sftp +slang spell test unicode X +xdg"

REQUIRED_USE="spell? ( edit )"

RDEPEND=">=dev-libs/glib-2.26.0:2
gpm? ( sys-libs/gpm )
kernel_linux? ( sys-fs/e2fsprogs )
samba? ( net-fs/samba )
sftp? ( net-libs/libssh2 )
slang? ( >=sys-libs/slang-2 )
!slang? ( sys-libs/ncurses:0=[unicode?] )
spell? ( app-text/aspell )
X? ( x11-libs/libX11
x11-libs/libICE
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libSM )"
DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( dev-libs/check )
"

S=${WORKDIR}/${MY_P}

pkg_pretend() {
if use slang && use unicode ; then
ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
fi
}

src_configure() {
[[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"

local myeconfargs=(
--disable-dependency-tracking
--disable-silent-rules
--enable-charset
--enable-vfs
--with-homedir=$(usex xdg 'XDG' '.mc')
--with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
$(use_enable kernel_linux vfs-undelfs)
$(use_enable mclib)
$(use_enable nls)
$(use_enable samba vfs-smb)
$(use_enable sftp vfs-sftp)
$(use_enable spell aspell)
$(use_enable test tests)
$(use_with gpm gpm-mouse)
$(use_with X x)
$(use_with edit internal-edit)
)
econf "${myeconfargs[@]}"
}

src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS README NEWS

# fix bug #334383
if use kernel_linux && [[ ${EUID} == 0 ]] ; then
fowners root:tty /usr/libexec/mc/cons.saver
fperms g+s /usr/libexec/mc/cons.saver
fi

if ! use xdg ; then
sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
-i "${ED%/}"/usr/libexec/mc/ext.d/*.sh || die
fi
}

pkg_postinst() {
elog "To enable exiting to latest working directory,"
elog "put this into your ~/.bashrc:"
elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
}

0 comments on commit 7154695

Please sign in to comment.