Skip to content

Commit

Permalink
net-proxy/trojan: version bump to 1.15.1
Browse files Browse the repository at this point in the history
Signed-off-by: Xin Yang <[email protected]>
Closes: gentoo#15181
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
YangMame authored and juippis committed Apr 1, 2020
1 parent 1879428 commit 719edaa
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-proxy/trojan/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST trojan-1.10.0.tar.gz 38230 BLAKE2B 2cfa77ebfbae62edef983d1e57e3ce00a61118f6
DIST trojan-1.12.3.tar.gz 41786 BLAKE2B f6306210a46316906b919fefb245a7c379ddcf785513bfbc3b8fc6a9c78e1c8cf22069533f58086fb4ffad05b625ab2b2fcacf2256520833ea49c0f307cee296 SHA512 f59afa28446dfef8680d7530aaff3609566b2873416bb11f8981ef111f63ed8deeacb2093373012547ede02dfb9beb8d92655b8f9ebafd6012c45b3ce787c22f
DIST trojan-1.13.0.tar.gz 44579 BLAKE2B 87aba58687fa5f42385893b8d919a46428b7d3cdbd2da38ee3e96900c11a6a3df7778c2a54295d5abb1964991d2d30433c4b37e70a9ca4ba184005d338bbed74 SHA512 5904ff75d348e9ccdd451836b1b05df6736e22530643d67a192e393fe32623576e0bbc106c883b6bc32daa2a086d5a7e42f836d684b66fc0deca019b14e3b3ab
DIST trojan-1.14.1.tar.gz 45884 BLAKE2B 2498476f7e1a2190e21d85b2572fbc91a77b50f9f2adc2d3c3c5cef2554da17f322fbdb23232a55c66c38a4f680175f5c2aa87cefc25853b2007de4bb8bac84d SHA512 c8fcdae584e742d958c896e3a18605f22073341a8227a1d7cb116e9f2ddadd6e5007bfe40ff765d564f8659cd9e9d11731d95a5c74459b0698cc48dac49ead19
DIST trojan-1.15.1.tar.gz 48121 BLAKE2B 38f288d8b9a6c7a98ada85b6b2dd2448604f54068334380c2e6b49d6ee015a1fad2847747734ef1e670d201d9625e64859ccddde5b924ea09c4e87e206997431 SHA512 5e0dfb46116b9de54f5d4e6d0646ab5ba3746143c5ad0f275c894929ba7fc840cacb187e514bbfaa770f0651fc4d3ff9e662f648f515a972ddf72ad0e93d616f
47 changes: 47 additions & 0 deletions net-proxy/trojan/trojan-1.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7} )

inherit cmake python-any-r1 systemd

DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
HOMEPAGE="https://github.com/trojan-gfw/trojan"
SRC_URI="https://github.com/trojan-gfw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="mysql test"

# Some hiccups setting up local network server.
RESTRICT="test"

RDEPEND="
>=dev-libs/boost-1.66.0:=
dev-libs/openssl:0=
mysql? ( dev-db/mysql-connector-c:= )
"
DEPEND="${RDEPEND}
test? ( net-misc/curl ${PYTHON_DEPS} )
"

src_configure() {
local mycmakeargs=(
-DENABLE_MYSQL=$(usex mysql)
-DSYSTEMD_SERVICE=ON
-DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
)
cmake_src_configure
}

src_install() {
cmake_src_install
newinitd "${FILESDIR}/trojan.initd" trojan
}

src_test() {
cmake_src_test -j1
}

0 comments on commit 719edaa

Please sign in to comment.