Skip to content

Commit

Permalink
media-sound/wavsplit: EAPI7 revbump, improve ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
mm1ke authored and a17r committed Sep 7, 2018
1 parent 1bd6ffd commit 71a91ba
Show file tree
Hide file tree
Showing 4 changed files with 50 additions and 12 deletions.
8 changes: 4 additions & 4 deletions media-sound/wavsplit/files/wavsplit-1.2.1-64bit.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- bak/wavsplit.c 2006-11-24 17:53:36.056883000 +0100
+++ wavsplit.c 2006-11-24 17:52:38.345276250 +0100
--- a/wavsplit.c 2006-11-24 17:53:36.056883000 +0100
+++ b/wavsplit.c 2006-11-24 17:52:38.345276250 +0100
@@ -403,7 +403,7 @@
ptr += 4; /* we move past fmt_ */
memcpy (&waveformat, ptr, sizeof (WAVEFORMAT));
Expand Down Expand Up @@ -27,8 +27,8 @@
printf ("Samplebits: %d\n", waveformat.wBitsPerSample);
printf ("Databytes: %llu\n\n", databytes);
printf ("Split Hours Mins Seconds Bytes %%\n");
--- bak/wavsplit.h 2006-11-24 17:53:36.056883000 +0100
+++ wavsplit.h 2006-11-24 17:43:58.648797250 +0100
--- a/wavsplit.h 2006-11-24 17:53:36.056883000 +0100
+++ b/wavsplit.h 2006-11-24 17:43:58.648797250 +0100
@@ -46,29 +46,29 @@
} TIMEFORMAT;

Expand Down
4 changes: 2 additions & 2 deletions media-sound/wavsplit/files/wavsplit-1.2.1-Makefile.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.old 2006-03-30 08:54:03.000000000 +0200
+++ Makefile 2006-03-30 08:55:04.000000000 +0200
--- a/Makefile 2006-03-30 08:54:03.000000000 +0200
+++ b/Makefile 2006-03-30 08:55:04.000000000 +0200
@@ -6,16 +6,16 @@
version = 1.2.1

Expand Down
12 changes: 6 additions & 6 deletions media-sound/wavsplit/files/wavsplit-1.2.1-large-files.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile 2004-11-17 23:19:17.000000000 +0100
+++ Makefile 2005-01-16 21:23:33.000000000 +0100
--- a/Makefile 2004-11-17 23:19:17.000000000 +0100
+++ b/Makefile 2005-01-16 21:23:33.000000000 +0100
@@ -6,7 +6,7 @@
version = 1.2.1

Expand All @@ -9,8 +9,8 @@
LIBS = -lm

all: wavsplit wavren
--- wavsplit.c 2004-11-17 23:19:17.000000000 +0100
+++ wavsplit.c 2005-01-16 22:04:39.000000000 +0100
--- a/wavsplit.c 2004-11-17 23:19:17.000000000 +0100
+++ b/wavsplit.c 2005-01-16 22:04:39.000000000 +0100
@@ -269,9 +269,9 @@
timepos * split)
{
Expand Down Expand Up @@ -161,8 +161,8 @@

while (to_be_read) {
n_read = read (ifd, buf, to_be_read);
--- wavsplit.h 2004-11-17 23:19:17.000000000 +0100
+++ wavsplit.h 2005-01-16 21:23:33.000000000 +0100
--- a/wavsplit.h 2004-11-17 23:19:17.000000000 +0100
+++ b/wavsplit.h 2005-01-16 21:23:33.000000000 +0100
@@ -121,15 +121,15 @@
static int split (unsigned int UseHours, unsigned int UseFrames,
unsigned int fps, unsigned int UseTrackLens,
Expand Down
38 changes: 38 additions & 0 deletions media-sound/wavsplit/wavsplit-1.2.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="Simple command line tool to split WAV files"
HOMEPAGE="https://sourceforge.net/projects/wavsplit/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
#-sparc, -amd64: 1.0: "Only supports PCM wave format" error message.
KEYWORDS="~amd64 -sparc ~x86"

PATCHES=(
"${FILESDIR}"/${P}-Makefile.patch
"${FILESDIR}"/${P}-large-files.patch
"${FILESDIR}"/${P}-64bit.patch
)

src_prepare() {
default
emake clean
}

src_compile() {
emake CC="$(tc-getCC)"
}

src_test() { :; } #294302

src_install() {
dobin wav{ren,split}
doman wav{ren,split}.1
dodoc BUGS CHANGES CREDITS README{,.wavren}
}

0 comments on commit 71a91ba

Please sign in to comment.