Skip to content

Commit

Permalink
dev-perl/Net-Pcap: Bump to version 0.180.0
Browse files Browse the repository at this point in the history
- EAPI6
- Add USE=examples
- Fix DESCRIPTION
- Disable silly author tests
- Fix tests against newer pcaps
- Enable tests
- Document comprehensive test notes

Upstream:
- Fix limitation of having only 1 callback function
- Add pcap_offline_filter()
- Add interop tests
- Add fixes for old Test::More's
- Append CCFLAGS instead of overriding

Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
kentfredric committed Dec 11, 2017
1 parent 775ef9d commit 71b3ea1
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-perl/Net-Pcap/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Net-Pcap-0.17.tar.gz 92853 BLAKE2B 147f0a11be36e7b5022f138611ad4226ea36d61902e966ab3400463aed4aecfd0022852df2589f363a6590270750b427cac9532f22a42e18d0f959a23e990ff1 SHA512 14747661b220b119b4182f13dbc1509cae5665e77588dbc8576f7d959f33ef6ee3785f2d9022093c1f1b808c37d04ee313f5ac39cc6eaa917962c9215c5a4de6
DIST Net-Pcap-0.18.tar.gz 94207 BLAKE2B 257e2b7c5bf6ad05936b64171db3ee530249f40d695ca2aba21d4bfe4796989e3a4aa955472b9c39e33aab5d67d2eebb26b43e173dbd359d01201926fa3a6b6e SHA512 63cc216345eb65b1e76efa657623c9d444d20f4b54ab0c75e787483baaa4f1de7e3a9294967aa7eccbdca04c60b089194dd7e0d19838f899b332c5881a8c7f6d
33 changes: 33 additions & 0 deletions dev-perl/Net-Pcap/Net-Pcap-0.180.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=SAPER
DIST_VERSION=0.18
DIST_EXAMPLES=( "eg/*" )
inherit perl-module eutils

DESCRIPTION="Interface to the pcap(3) LBL packet capture library"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="net-libs/libpcap
dev-perl/IO-Interface"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-${DIST_VERSION}-test-error.patch"
)

src_test() {
if [[ $EUID != 0 ]]; then
elog "Comprehensive testing of this module requires root permissions."
elog "For details, see:"
elog "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
fi
perl_rm_files t/pod{,cover,spell}.t t/distchk.t t/portfs.t
perl-module_src_test
}
39 changes: 39 additions & 0 deletions dev-perl/Net-Pcap/files/Net-Pcap-0.18-test-error.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
From 7c831efcb06d6254e54423cdcd95bebbb7725270 Mon Sep 17 00:00:00 2001
From: Kent Fredric <[email protected]>
Date: Fri, 8 Dec 2017 17:52:13 +1300
Subject: Allow error message to be a suffix

Previously, the error message emitted by the native calls was of the
form:

'syntax error'

However, more recently the error message takes the form:

'syntax error in filter expression: syntax error'

This patch pretends the part before the ":" is functionally equivalent
to a line start, for the purposes of testing.

Bug: https://github.com/maddingue/Net-Pcap/issues/8
Bug: https://github.com/maddingue/Net-Pcap/pull/9
---
t/09-error.t | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/t/09-error.t b/t/09-error.t
index 90337b8..eee679d 100644
--- a/t/09-error.t
+++ b/t/09-error.t
@@ -22,7 +22,7 @@ is( $@, '', "compile() with an invalid filter string" );
is( $res, -1, " - result must not be null: $res" );
eval { $err = Net::Pcap::geterr($pcap) };
is( $@, '', "geterr()" );
-like( $err, '/^(?:parse|syntax) error$/', " - \$err must not be null: $err" );
+like( $err, '/(^|: )(?:parse|syntax) error$/', " - \$err must not be null: $err" );

# Testing compile() with a valid filter
eval { $res = Net::Pcap::compile($pcap, \$filter, "tcp", 0, $mask) };
--
2.14.3

0 comments on commit 71b3ea1

Please sign in to comment.