forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST qpdf-5.1.1.tar.gz 7662701 SHA256 95d355d8fa5e1c677e04d884161de94f5438bf3bdc1638498796b042bad4a726 SHA512 236132290694730d7de08635560435d34ae44f4edbc1b887e494f2ee183271331827226e7e29e539d25d5a2ca1dd5815a387c46edc0b6fd898436bbb674d9993 WHIRLPOOL 66eee10dc5163f1e53afcbd02b71bab73598c28ebb9b005c26af4e58396fd693af7ed76a17fd0c29819b0fa08a71ea0158c76bfa0b0d452a78bb357277644459 | ||
DIST qpdf-5.1.2.tar.gz 7664268 SHA256 e9dd8d5d0a322078ffd573f057f03d24a734cc5b7dd925b089ebcb0f6e867bfd SHA512 be2fe3f1127532edc1b3d9af2d25df64c2c04c402cfef8d1ca5ed77129c2f17ef3435abb6c630b260ee4be8458984c0fbf0abfb6cda82ef4fa74dc23ca7a8864 WHIRLPOOL 5ec875f0ea73aa044c671f4ea9e5b69c74c188463ad58006a55ed395fed4e0184baad760486596586866b9f701ae5e211ac08ade1eff54028e20c6c1462ee629 | ||
DIST qpdf-5.1.3.tar.gz 7681578 SHA256 d5164bdad3afc381568dbe8e1509a4a6a911d4d077f1fc20b9866ef8fad901d3 SHA512 676cc6db27dcbcdece21cb427c6aae14646389f4000ff111feee8fdbbb03fe715035e5236a08db4137f275a09ed0dda5c80afbdc5093fe7f56b69a0e335ab73a WHIRLPOOL 96cf06c0da63f9f3f5bccd422875c23e473443a4552de3c23ab9971104876fb5463cb6b7db86faee3aac04bddd9b59391093a7d5840cad801093162561ba459d | ||
DIST qpdf-6.0.0.tar.gz 8344860 SHA256 a9fdc7e94d38fcd3831f37b6e0fe36492bf79aa6d54f8f66062cf7f9c4155233 SHA512 303e3cc77ddb87b9494e26c35e0b45b42f73692054c56a00f2e4f1922633c6ebb45c8684992cd9bf32f03366fcc4cd7e7ec6fb9432d2dbba6e0b24395909b5bf WHIRLPOOL f9fae783c16a93826f825a8efe1a116cbde00fb19b8b56dbfcad7878557c106c8f7a58945af3002f2a72aa032247008013edce8943a45cca8c186b68bf2b5cd3 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils | ||
|
||
DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files" | ||
HOMEPAGE="http://qpdf.sourceforge.net/" | ||
SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz" | ||
|
||
LICENSE="Artistic-2" | ||
SLOT="0/17" # subslot = libqpdf soname version | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris" | ||
IUSE="doc examples static-libs test" | ||
|
||
RDEPEND="dev-libs/libpcre | ||
sys-libs/zlib | ||
>=dev-lang/perl-5.8" | ||
DEPEND="${RDEPEND} | ||
test? ( | ||
sys-apps/diffutils | ||
media-libs/tiff | ||
app-text/ghostscript-gpl | ||
)" | ||
|
||
DOCS=( ChangeLog README TODO ) | ||
|
||
src_prepare() { | ||
# manually install docs | ||
sed -i "/docdir/d" make/libtool.mk || die | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
$(use_enable static-libs static) \ | ||
$(use_enable test test-compare-images) | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
if use doc ; then | ||
dodoc doc/qpdf-manual.pdf | ||
dohtml doc/* | ||
fi | ||
|
||
if use examples ; then | ||
dobin examples/build/.libs/* | ||
fi | ||
|
||
prune_libtool_files | ||
} |