forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/docker-runc: Update snapshot for docker-17.04.x
Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
60 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST docker-runc-1.0.0_rc2_p20170201.tar.gz 560793 SHA256 11f69923a786efb82b65d9f1eec0ac665a985e631a67f3f4d466dac720efacdd SHA512 8c19a02a55108cef36cbd1ff739a3c8e2962d188c426517fce91483ec525546d39c14072f0a0f2471b6b70a05cf6c1f0e99cfeb5e87203fcbae955bd5f5bd16b WHIRLPOOL 8a1f44234c668aca5c53e401ce80e2c297ad9c7ed0b10d782494e93020f824e6d5e3a00be221f1ff5d039df998c43556228503788181a45256d91278dd005721 | ||
DIST docker-runc-1.0.0_rc2_p20170222.tar.gz 560798 SHA256 ab7913b8062f77c0a2b16ae335d74eb78aa85e8d4dcccbf0793b14caf1a3f0b2 SHA512 1ea7ed8a98b2cbc508933608d7dc16b26c1507021200691e66fa61d4c567a5437aafae8b9710bf29ba94a8c4853de7f9e38e9e09de9a358a68e0e431771a13cc WHIRLPOOL e198528c956de5921ac5fa4395d0391d4b94413b46d82596bc47c525365e80b3b839df07b7f63642ad7d9c6f078c265f6e0d16397dba086c152e50ee0ebdb7be | ||
DIST docker-runc-1.0.0_rc2_p20170308.tar.gz 561400 SHA256 bdd0fc0b5db42bb1fc439d5a5d6347d97b285e676559afb620ffd9f62fc1de26 SHA512 f17c7ff09578573a161f14616446e74d92d66039c1462bce23ea507b151eb66ede12d2ca583d3dace21d186a80bdadf222fc180bf1123e29c68e43f2f2d949c8 WHIRLPOOL f6853ccdd09ca1481828b20e64403151cd9c5d46ceb81c50e884d47e18f8594c21bf53102b252852b259b6b0186f54f070fb7f3c7e4447123cbf05aa69233035 | ||
DIST docker-runc-1.0.0_rc2_p20170310.tar.gz 561483 SHA256 b5c50d7d9a5f610d5424f96196efa306ec708fd9299302dd919545099c16b7c1 SHA512 225a37b4a3a79ff0d7a3e74b997f6e5547e270d02c58e65ccb5ea2d81771c489378727bd6abf2f445ea94c2e7717e2991da9fb4cab74327fd57c0e6218143cc3 WHIRLPOOL ecf6ee1d2ed977b74d0d5d5dbf3ff2cc96728bd680a13c58f715dea2401002b0da461d6d2d9ac6af35f290a356821b19175e6f5004fa25b3c8d82eca69d87965 |
59 changes: 59 additions & 0 deletions
59
app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170310.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,59 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
EGO_PN="github.com/docker/${PN/docker-}" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
inherit golang-vcs | ||
else | ||
MY_PV="${PV/_/-}" | ||
EGIT_COMMIT="9c2d8d184e5da67c95d601382adf14862e4f2228" | ||
RUNC_COMMIT="9c2d8d1" # Change this when you update the ebuild | ||
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~ppc64" | ||
inherit golang-vcs-snapshot | ||
fi | ||
|
||
DESCRIPTION="runc container cli tools (docker fork)" | ||
HOMEPAGE="http://runc.io" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="apparmor hardened +seccomp" | ||
|
||
RDEPEND=" | ||
apparmor? ( sys-libs/libapparmor ) | ||
seccomp? ( sys-libs/libseccomp ) | ||
!app-emulation/runc | ||
" | ||
|
||
S=${WORKDIR}/${P}/src/${EGO_PN} | ||
|
||
RESTRICT="test" | ||
|
||
src_compile() { | ||
# Taken from app-emulation/docker-1.7.0-r1 | ||
export CGO_CFLAGS="-I${ROOT}/usr/include" | ||
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '') | ||
-L${ROOT}/usr/$(get_libdir)" | ||
|
||
# Setup GOPATH so things build | ||
rm -rf .gopath | ||
mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")" | ||
ln -sf ../../../.. .gopath/src/"${GITHUB_URI}" | ||
export GOPATH="${PWD}/.gopath:${PWD}/vendor" | ||
|
||
# build up optional flags | ||
local options=( | ||
$(usex apparmor 'apparmor') | ||
$(usex seccomp 'seccomp') | ||
) | ||
|
||
emake BUILDTAGS="${options[*]}" \ | ||
COMMIT="${RUNC_COMMIT}" | ||
} | ||
|
||
src_install() { | ||
dobin runc | ||
} |