Skip to content

Commit

Permalink
app-admin/ansible-lint: Initial commit.
Browse files Browse the repository at this point in the history
Original 3.4.9 ebuild by Johann "ercpe" Schmitz & Justin "jlec" Lecher in the
last-hope overlay.

Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
tonyvroon committed Aug 8, 2018
1 parent 9d77264 commit 720a046
Show file tree
Hide file tree
Showing 3 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/ansible-lint/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST ansible-lint-3.4.23.tar.gz 36922 BLAKE2B a012155d9608ce0517f152837cc7f5f8330848f3e6b6b8b62b1985c9aae5260d3b8c2e9016f945a30b8433387549a9421970d9f56fc32ff9aac25a71dc150285 SHA512 4b2357327319f2cc2c0863ed74af3c799afa97f6e8e1885f9c621a9b0b4ed4b33c731f4a0e8557bf7d03f4e1680a06e60b8602b48fbb55c55325f1dda31a51e7
36 changes: 36 additions & 0 deletions app-admin/ansible-lint/ansible-lint-3.4.23.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

MY_P=${P/_/}

DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
HOMEPAGE="https://github.com/willthames/ansible-lint"
SRC_URI="https://github.com/willthames/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

S="${WORKDIR}/${MY_P}"

CDEPEND="app-admin/ansible[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/flake8[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
)
${CDEPEND}"
RDEPEND="${CDEPEND}"

python_test() {
nosetests || die
}
13 changes: 13 additions & 0 deletions app-admin/ansible-lint/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Tony Vroon</name>
</maintainer>
<upstream>
<remote-id type="pypi">ansible-lint</remote-id>
<remote-id type="github">willthames/ansible-lint</remote-id>
<bugs-to>https://github.com/willthames/ansible-lint/issues</bugs-to>
</upstream>
</pkgmetadata>

0 comments on commit 720a046

Please sign in to comment.