Skip to content

Commit

Permalink
gnome-base/gnome-settings-daemon: bump to 3.32.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <[email protected]>
  • Loading branch information
leio committed Sep 8, 2019
1 parent 06e2701 commit 7210849
Show file tree
Hide file tree
Showing 2 changed files with 137 additions and 0 deletions.
2 changes: 2 additions & 0 deletions gnome-base/gnome-settings-daemon/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST gnome-settings-daemon-3.30.2-patchset.tar.xz 20132 BLAKE2B b8f2573e806ee5aedcc1476de3550cdc39933c869d64c9d13e463cdf27fa7695e69e57612738fa5438988eda78ae998808508c94fbf841ec037eb1f103921458 SHA512 7318029f4145379b05f7a95686917b4ea7623fd0059559930072350db12170d6083d75c170578516bcede5282da677013086c343abe779b9d1696bd882b7e34d
DIST gnome-settings-daemon-3.30.2.tar.xz 1376776 BLAKE2B a7cf276c5a802b7d9a6f738048b5bc34d97f79723c6f4cfb4f29ac3ed0f43e307cbdd6793e8d8115f51981ee576737d75c58531dcd5d0779d9f3670b68523a60 SHA512 517cb6bab3da10d5d47ab9c9690da3fa23e64d023d01b7cc101441f6b65639f3b6c8d0a0d19da80b22924b3dbe6430b2573fb861060f02fda248b24f00be5d84
DIST gnome-settings-daemon-3.32.1-patchset.tar.xz 9840 BLAKE2B 0b0249b6335fc64c111cfd4c221b408460105bd544527ca29a32b2ceb82d39c1ca8c9813916cde9afdac1cf146c1286ed937dadb07eb0263b5ab3ada2a95e0aa SHA512 175f4d0200b88b696b73fc7e7b10065b3e6f046e48955408cc438499fdc6464483420b4801dbb77b5ae819cb52a131e2594a628b9731eaa167b802b5b2cbe855
DIST gnome-settings-daemon-3.32.1.tar.xz 1372968 BLAKE2B ba0596d9f2019f2ecff32b70c03d962dd7966c282d1fb0ea94c38fc895b7ef788d9dd179a037b74a319ca520811e985465578a725bf14d1eff92846f188445ea SHA512 8d6aca1041cbd50d7dda67dc711269a51c4a5148d55dc63969f47c21bf309126f5d5cb13c1e6fa9e6498fbb30dc70fa7a049fead7d32c6a20d550da0ce8828c3
135 changes: 135 additions & 0 deletions gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.32.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,135 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{3_5,3_6,3_7} )

inherit gnome.org gnome2-utils python-any-r1 meson udev virtualx xdg

DESCRIPTION="Gnome Settings Daemon"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"

LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
IUSE="+colord +cups debug elogind input_devices_wacom networkmanager smartcard systemd test +udev wayland"
REQUIRED_USE="
^^ ( elogind systemd )
input_devices_wacom? ( udev )
wayland? ( udev )
"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"

# >=polkit-0.114 for ITS translation rules of .policy files
COMMON_DEPEND="
>=sci-geosciences/geocode-glib-3.10
>=dev-libs/glib-2.56:2
>=gnome-base/gnome-desktop-3.11.1:3=
>=gnome-base/gsettings-desktop-schemas-3.27.90
>=x11-libs/gtk+-3.15.3:3[X,wayland?]
>=dev-libs/libgweather-3.9.5:2=
colord? (
>=x11-misc/colord-1.0.2:=
>=media-libs/lcms-2.2:2 )
media-libs/libcanberra[gtk3]
>=app-misc/geoclue-2.3.1:2.0
>=x11-libs/libnotify-0.7.3
>=media-sound/pulseaudio-2[glib]
>=sys-auth/polkit-0.114
>=sys-power/upower-0.99:=
x11-libs/libX11
udev? ( virtual/libgudev:= )
wayland? ( dev-libs/wayland )
input_devices_wacom? ( >=dev-libs/libwacom-0.7
>=x11-libs/pango-1.20.0
x11-libs/gdk-pixbuf:2 )
smartcard? ( >=dev-libs/nss-3.11.2 )
cups? ( >=net-print/cups-1.4[dbus] )
networkmanager? ( >=net-misc/networkmanager-1.0 )
media-libs/alsa-lib
x11-libs/libXi
x11-libs/libXext
media-libs/fontconfig
"
# logind needed for power and session management, bug #464944
# gnome-session-3.27.90 and gdm-3.27.9 adapt to A11yKeyboard component removal (moved to shell dealing with it)
RDEPEND="${COMMON_DEPEND}
gnome-base/dconf
elogind? ( sys-auth/elogind )
systemd? ( sys-apps/systemd )
!<gnome-base/gnome-session-3.27.90
!<gnome-base/gdm-3.27.90
"
# rfkill requires linux/rfkill.h (and USE=udev), thus linux-headers dep, not os-headers. If this package wants to work on other kernels, we need to make rfkill conditional instead
DEPEND="${COMMON_DEPEND}
sys-kernel/linux-headers
dev-util/glib-utils
dev-util/gdbus-codegen
x11-base/xorg-proto
${PYTHON_DEPS}
test? (
$(python_gen_any_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
$(python_gen_any_dep 'dev-python/dbusmock[${PYTHON_USEDEP}]')
gnome-base/gnome-session )
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"

# Tests go a bit better in 3.26, but still fail some for me; revisit with 3.30+ (incompatible build system python needs until then as well)
#RESTRICT="!test? ( test )"

PATCHES=(
# Translation updates from gnome-3-30 branch
# Allow disabling udev and networkmanager on Linux
# Make colord and wacom optional
"${WORKDIR}"/patches/
)

python_check_deps() {
if use test; then
has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]" &&
has_version "dev-python/dbusmock[${PYTHON_USEDEP}]"
fi
}

pkg_setup() {
python-any-r1_pkg_setup
}

src_configure() {
local emesonargs=(
#-Dnssdb_dir # TODO: Is the default /etc/pki/nssdb path correct for our nss?
-Dudev_dir="$(get_udevdir)"
-Dalsa=true
$(meson_use udev gudev)
$(meson_use colord)
$(meson_use cups)
$(meson_use networkmanager network_manager)
$(meson_use udev rfkill)
$(meson_use smartcard)
$(meson_use input_devices_wacom wacom)
$(meson_use wayland)
)
meson_src_configure
}

src_install() {
meson_src_install
# Don't auto-suspend by default on AC power
insinto /usr/share/glib-2.0/schemas
doins "${FILESDIR}"/org.gnome.settings-daemon.plugins.power.gschema.override
}

src_test() {
virtx meson_src_test
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit 7210849

Please sign in to comment.