Skip to content

Commit

Permalink
games-misc/katawa-shoujo: bump to vn. 1.3.1
Browse files Browse the repository at this point in the history
git patch provided by proxy maintianer via the gentoo bug

Gentoo bug:  574018

Package-Manager: portage-2.2.26
  • Loading branch information
Ian Delaney committed Feb 12, 2016
1 parent 9160e21 commit 723184c
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-misc/katawa-shoujo/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST katawa-shoujo-1.3.1.tar.bz2 496188604 SHA256 ec5a05cfcf1d5981ecdbfa71904c279a215e79bdfeb256b2ad6927109a0007da SHA512 d5f1b49c60b70b272dd5d62c1d49cb9e3c17e3f77339fc593db2122f1c140005bc23ecb7ad9b0d93c0701c77f9bcfcd5c1c67db1cbe3034a3be42a4309387809 WHIRLPOOL e8d1572c08171febb3a25e6c7bae2ad66a6ba0bccd1f297afe0430e57fa71ade850d19f4a472c9932f9b2421c5bf2c482b006000eff126e46ce3cd6a727652ab
DIST katawa-shoujo-1.3.tar.bz2 496193762 SHA256 a7fbe9330e60a5457ce504f20de357191f0809beab345a9c00974fedd74ae573 SHA512 228ea474746541e0f812789a504c75005c9f3d496d9a255aba77ed926cb6302ed9815126b5facba6a29e560fbfca2ac2d584c62870157704ed7e99c9eabed9b6 WHIRLPOOL 3ccd9d9f555e817e805fc294f41bd0d7c0937ad71bc31d819be54e0bfae4a8a4e4cedee7cdff4cff7f389c26578a119989c7f029014992ebeb5a6afa9dc55931
DIST katawa-shoujo-256.png 59803 SHA256 8130b39af5341b0e1c85cbd6ef5be229de2877d696e5b372e1aacf176778df45 SHA512 7d920c24f4182ba72d5b3d641d7d373c166ca4c7d0b6a396f5e3b9281cb43f7e6e8e761f2f181ff061705118b3080807866fcd290d2b471e98c3a584d5fa8e0e WHIRLPOOL d2b06b26d2ea5bae5292fc5e6f3f4571fa82a4f70155e38a3c8a21778caabc37b2a13b2cb7637a0fb05a55243a63e23c96d0538bbcbc631810f15c069d26f590
DIST katawa-shoujo-48.png 3621 SHA256 a366a52fd9dd241182d163e28a37f537fa71d5d46f1fc899da08b492c371a0fd SHA512 ad24156cf446ffe92068baaa6d512e6bab90587db5ce01b3c18e6c42bb9b8c91f7eae3e9547099d3f8f0a5d3f144676c3499c0a38d9af845abf79e153b543bef WHIRLPOOL b62253218dbb981f32007e22cdd36decac8948e4dff416ca60de3daaab8cfad9773622e194b885c0145a499008751c5a09184b7f0a0dc3b9153d751dd0d1b584
83 changes: 83 additions & 0 deletions games-misc/katawa-shoujo/katawa-shoujo-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils gnome2-utils

DESCRIPTION="bishoujo-style visual novel by Four Leaf Studios"
HOMEPAGE="http://katawa-shoujo.com/"
SRC_URI="http://dl.katawa-shoujo.com/gold_1.3.1/%5B4ls%5D_katawa_shoujo_1.3.1-%5Blinux-x86%5D%5B18161880%5D.tar.bz2 -> ${P}.tar.bz2
https://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-48.png
https://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-256.png"

# bundled renpy includes licenses of all libraries
LICENSE="CC-BY-NC-ND-3.0
!system-renpy? ( MIT PSF-2 LGPL-2.1 || ( FTL GPL-2+ ) IJG libpng ZLIB BZIP2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc +system-renpy"

RDEPEND="system-renpy? ( games-engines/renpy )"

REQUIRED_USE="!system-renpy? ( || ( amd64 x86 ) )"

# Binaries are built extremely weirdly, resulting in errors like:
# BFD: Not enough room for program headers, try linking with -N
#
# Technically, we could make this unconditional because there are no other
# binaries, but it's still good practice.
RESTRICT="!system-renpy? ( strip )"

QA_PREBUILT="/opt/${PN}/lib/*"

S="${WORKDIR}/Katawa Shoujo-${PV}-linux"

src_install() {
if use system-renpy; then
insinto "/usr/share/${PN}"
doins -r game/.

make_wrapper ${PN} "renpy '/usr/share/${PN}'"
else
insinto "/opt/${PN}"
doins -r game localizations renpy "Katawa Shoujo."{py,sh}

local host="${CTARGET:-${CHOST}}"
local arch="${host%%-*}"

cd lib
insinto "/opt/${PN}/lib"
doins -r linux-${arch} pythonlib2.7
cd ..

fperms +x "/opt/${PN}/lib/linux-${arch}/"{python,"Katawa Shoujo"} \
"/opt/${PN}/Katawa Shoujo."{py,sh}

make_wrapper ${PN} "./Katawa\ Shoujo.sh" "/opt/${PN}"
fi

local i
for i in 48 256; do
newicon -s ${i} "${DISTDIR}"/${PN}-${i}.png ${PN}.png
done

make_desktop_entry ${PN} "Katawa Shoujo"

if use doc; then
dodoc "Game Manual.pdf"
fi
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 723184c

Please sign in to comment.