Skip to content

Commit

Permalink
dev-libs/gom: version bump to 0.3.2
Browse files Browse the repository at this point in the history
Now provides python overrides for introspection, hence the "weird" REQUIRED_USE.

Package-Manager: portage-2.2.26
  • Loading branch information
EvaSDK committed Dec 28, 2015
1 parent 610a163 commit 7250b77
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/gom/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gom-0.3.0.tar.xz 382924 SHA256 352a8bee8dc47e7bd5d08af35b0d67e1f3c54bca23a058a00004cb56ede6f4fd SHA512 ab26dbbb4cbeaa637ca835eff96caf647428505129652d0229808951b3ba5ec2225e2d37054a6b61ccad59954fda7d95bb04d61f75c1ec1ebbc1abea7025b627 WHIRLPOOL 98b7fc358635e17c1c878f2439f667cecd9304a8b5d10023d2e084d01e2950201404156add20da5e05f2a1e09bd42811a31f0765fa9e196e58d4c09496ba7664
DIST gom-0.3.1.tar.xz 385836 SHA256 7951eb46ee784cbdbee6e3f2da084ffbf776c11ca1c904404b05feafe37e38f5 SHA512 7596b7be0de6f10ef1fbe8a278d917c07ecc714e9af24f2b61a7d871c6a1b1cf19ea92d5b4fbf7802c9c097dc2ae7a65ac47b8ca8f6689b49a3e4930cff6d54c WHIRLPOOL 9fa3a42411e3892a3648f31614462d43b5a4f52a166e5edd80e97741427a9444c39d2200a4ce1ac3e1e87d3b3e974b9dad6f11ee252ba3d10fa1d63b00a09bde
DIST gom-0.3.2.tar.xz 410300 SHA256 bce8f0f94af6ff7847b853580ba6baebbab8ae531cedb0c78a5c473f39c758fd SHA512 a7bfb263e5ff6f89768d8fcbdcc949d4ec9b82ecbb80952becd357a3d5781a60e52a327e865e39e46d542b2a2c5e5c861e5302d7ae3c3a2258d3c3f698263675 WHIRLPOOL b676f4117c66fbe47b4216b3f5e4259e0569bcf355ca2f474498c29218d42093ac66e3afb0eb1cd946837e813f4e7c3ff981e99a726458150c00c89653d06559
77 changes: 77 additions & 0 deletions dev-libs/gom/gom-0.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="yes"
PYTHON_COMPAT=( python{3_4,3_5} )

inherit gnome2 python-r1

DESCRIPTION="GObject to SQLite object mapper library"
HOMEPAGE="https://wiki.gnome.org/Projects/Gom"

LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="+introspection python"
REQUIRED_IUSE="python? ( ${PYTHON_REQUIRED_USE} introspection )"

RDEPEND="
>=dev-db/sqlite-3.7:3
>=dev-libs/glib-2.36:2
introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
python? (
${PYTHON_DEPS}
>=dev-python/pygobject-3.16:3[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.14
>=dev-util/intltool-0.40.0
sys-devel/gettext
virtual/pkgconfig
x11-libs/gdk-pixbuf:2
"
# TODO: make gdk-pixbuf properly optional with USE=test

pkg_setup() {
use python && python_setup
}

src_prepare() {
gnome2_src_prepare

use python && python_copy_sources
}

src_configure() {
# glibtest is a relic from AM_PATH_GLIB macro
local myconf=(
--disable-static
--disable-glibtest
)

gnome2_src_configure \
${myconf[@]} \
--disable-python \
$(use_enable introspection) \

if use python ; then
python_foreach_impl run_in_build_dir \
gnome2_src_configure \
${myconf[@]} \
--enable-python
fi
}

src_install() {
gnome2_src_install

if use python ; then
docinto examples
dodoc examples/*.py

python_foreach_impl run_in_build_dir \
emake DESTDIR="${D}" install-overridesPYTHON
fi
}

0 comments on commit 7250b77

Please sign in to comment.