Skip to content

Commit

Permalink
app-text/jabref-bin: Add live ebuild
Browse files Browse the repository at this point in the history
Live ebuild fetches daily snapshots of the from upstream.

Package-Manager: Portage-2.3.8, Repoman-2.3.3
Signed-off-by: Nicolas Bock <[email protected]>
  • Loading branch information
jonasstein authored and nicolasbock committed Nov 1, 2017
1 parent 53ce4e5 commit 726d559
Showing 1 changed file with 42 additions and 0 deletions.
42 changes: 42 additions & 0 deletions app-text/jabref-bin/jabref-bin-4.9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils java-pkg-2

DESCRIPTION="Java GUI manages bibliographies in a BibTeX database"
HOMEPAGE="http://www.jabref.org/"
KEYWORDS=""

LICENSE="MIT"
SLOT="0"

DEPEND="app-arch/unzip"

RDEPEND="
|| (
dev-java/oracle-jre-bin:1.8[javafx]
dev-java/oracle-jdk-bin:1.8[javafx]
)
>=virtual/jre-1.8
"

S="${WORKDIR}"

src_unpack() {
einfo "Downloading the latest Jabref development snapshot."
einfo "Upstream updates these a few times per day."
wget "https://builds.jabref.org/master/JabRef--master--latest.jar" -O ${P}.jar || die "wget failed"
unzip ${P}.jar images/external/JabRef-icon-48.png || die "icon extraction failed"
}

src_install() {
java-pkg_newjar "${P}.jar"
java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
newicon images/external/JabRef-icon-48.png JabRef-bin-icon.png
make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
ewarn "Jabref 4.x will convert old 3.x format .bib databases to a new format."
ewarn "The conversion is irreversible, backup .bib files before starting Jabref."
ewarn "Jabref 4.x is under heavy development and very unstable."
}

0 comments on commit 726d559

Please sign in to comment.