Skip to content

Commit

Permalink
dev-lang/eisl: bump to 5.00
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Jul 15, 2024
1 parent 1c070ee commit 727a143
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/eisl/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST eisl-3.95.tar.gz 2438216 BLAKE2B 927af9a8b0469fcda16501a6fffba60eebc708dcfaba1b076b0ffe80396c285fc1fbb427694548418f76102451f7e37506686bf8d025decd04245e105fa618f7 SHA512 50e4159bbbc3c72fe985db3b2d77be63f2e8197027e97ac5af0e9316e5f817497bfc0a9f7cf0b0624bb8baf2cf28b5b94556ad77edcdee2e8e8a6d63a74e02a2
DIST eisl-4.00.tar.gz 2299966 BLAKE2B fe2d4e486d459866870b0baa23d2eb32890e1661460116508bd18aa401ec71cb68395bf857c98ba749005dcfd0985ab628274800a32e749abf27a767a2ce8615 SHA512 0b4d225f6068a9ff05c6483663b68ae920a1f63e30b47e7350243a70902ae7f5818cf4713fdd45c223e858a4e435d5e93f0944965af1db3f8d9d48f0e2db8239
DIST eisl-5.00.tar.gz 2995464 BLAKE2B ecfc577df2e2b470845a0f3cbaa646408b8d5ec72c0b0e86263c443d6cf0aad0401d7f70e826db71ba824f7659fb4620a83aa81840e2c1b7822c97ada5212d86 SHA512 c82aaac0a9878f33abfe5edd54a37884965a00e6f37e901f81e49537afe8a4891343096d6089058c8ce0df4e8cc89f1f6c179f97eb950e45b949e95d9e094ddf
52 changes: 52 additions & 0 deletions dev-lang/eisl/eisl-5.00.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"

if [[ "${PV}" == *9999* ]] ; then
inherit git-r3

EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
else
SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
fi

LICENSE="BSD-2"
SLOT="0"
RESTRICT="test" # Tests run cppcheck (and fail)

DOCS=( README{,-ja}.md documents )

RDEPEND="
sys-libs/ncurses:=
"
DEPEND="
${RDEPEND}
"

PATCHES=( "${FILESDIR}/${PN}-3.60-Makefile.patch" )

src_compile() {
emake CC="$(tc-getCC)" clean edlis eisl
}

src_install() {
exeinto /usr/bin
doexe edlis eisl

# Compilation of ISLisp files on installation fails.
# Do not compile them and mimic "make install".
insinto "/usr/share/${PN}"
doins -r library
doins fast.h ffi.h

einstalldocs
}

0 comments on commit 727a143

Please sign in to comment.