Skip to content

Commit

Permalink
games-arcade/performous: Fix building against boost 1.70
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/671594
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Apr 16, 2019
1 parent eeea873 commit 727bfae
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
52 changes: 52 additions & 0 deletions games-arcade/performous/files/performous-1.1-boost-1.70.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
https://bugs.gentoo.org/671594

--- a/game/audio.cc
+++ b/game/audio.cc
@@ -77,7 +77,7 @@
static ptime getTime() { return microsec_clock::universal_time(); }
// Conversion helpers
static double getSeconds(time_duration t) { return 1e-6 * t.total_microseconds(); }
- static time_duration getDuration(double seconds) { return microseconds(1e6 * seconds); }
+ static time_duration getDuration(double seconds) { return microseconds(static_cast<long long>(1e6 * seconds)); }

mutable boost::mutex m_mutex;
ptime m_baseTime; ///< A reference time (corresponds to m_basePos)
@@ -149,7 +149,7 @@
int64_t m_pos; ///< Current sample position
bool m_preview;
AudioClock m_clock;
- time_duration durationOf(int64_t samples) const { return microseconds(1e6 * samples / srate / 2.0); }
+ time_duration durationOf(int64_t samples) const { return microseconds(static_cast<long long>(1e6 * samples / srate / 2.0)); }
public:
bool suppressCenterChannel;
double fadeLevel;
--- a/game/backgrounds.hh
+++ b/game/backgrounds.hh
@@ -7,6 +7,7 @@
#include <boost/scoped_ptr.hpp>
#include <boost/thread/mutex.hpp>
#include <boost/thread/thread.hpp>
+#include <boost/noncopyable.hpp>
#include <vector>

/// songs class for songs screen
--- a/game/songs.hh
+++ b/game/songs.hh
@@ -6,6 +6,7 @@
#include <boost/scoped_ptr.hpp>
#include <boost/thread/mutex.hpp>
#include <boost/thread/thread.hpp>
+#include <boost/noncopyable.hpp>
#include <set>
#include <sstream>
#include <vector>
--- a/game/svg.cc
+++ b/game/svg.cc
@@ -4,6 +4,7 @@
#include "configuration.hh"
#include "../common/image.hh"

+#include <boost/smart_ptr/shared_ptr.hpp>
#include <librsvg/rsvg.h>
#include <iostream>

1 change: 1 addition & 0 deletions games-arcade/performous/performous-1.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -64,6 +64,7 @@ PATCHES=(
"${FILESDIR}"/${P}-linguas.patch
"${FILESDIR}"/${P}-nomancompress.patch
"${FILESDIR}"/${P}-jpeg-9c.patch
"${FILESDIR}"/${P}-boost-1.70.patch
)

src_prepare() {
Expand Down

0 comments on commit 727bfae

Please sign in to comment.