Skip to content

Commit

Permalink
Merge remote-tracking branch 'remotes/github/pr/709'
Browse files Browse the repository at this point in the history
  • Loading branch information
Markos Chandras committed Jan 23, 2016
2 parents 51a5728 + 09f8d72 commit 7284695
Show file tree
Hide file tree
Showing 2 changed files with 112 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/rb_libtorrent/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST libtorrent-rasterbar-1.0.4.tar.gz 3297242 SHA256 1f567823133b1493b9717afc83
DIST libtorrent-rasterbar-1.0.5.tar.gz 3302804 SHA256 474a43da2147bec7e333c10f70b07221f4732dd67e071d5e90acc7edb8f657b0 SHA512 1ec54dfac1555ac1a843d12e239d781e940ef81ca13a943c58812b0fb62686e89bc5e0135feb94267fb624077cb0ad9971d496d8474b91f3687ef3b90a524df6 WHIRLPOOL a84f7895fdfda2020630c387eedd9b5a82ddc51af6b35fe8a2e7216495baaf9901a58ef2335c254fa3c2e0c713c7e6a1d9f976984fa5998329e47bc95ae22a63
DIST libtorrent-rasterbar-1.0.6.tar.gz 3307491 SHA256 c97de804b77f44591801631aca3869567671df2d3e2afe7f5453d8db2478fd61 SHA512 798529f877dc94aa8eb635677a2fffb6deead3937153e78ac5344fd81422f9fd9594e227db3ec0ae954dfc59e4dd5f3b8f6dbed2e3aa1f9a710c32b0622f54ee WHIRLPOOL 250651925c4d09b6e73c3c3e4b1e1f9131b49dbf3bdbeda3d683f204d4cebbcb865b694aa5e079072a73be922a25a2378094744bf4dd3bc4e220e9b0115342b6
DIST libtorrent-rasterbar-1.0.7.tar.gz 3298005 SHA256 3e16e024b175fefada17471c659fdbcfab235f9619d4f0913faa13cb02ca8d83 SHA512 d60736af4b7c38317821810995dd9bec21688a9506e9b908394c2a1a87acd2abf23000856dedcad487b9ecc7b5680f83cfc09ff9db79af00fe21e94337daeacf WHIRLPOOL aff289e3ca85eedf688e8a898f0164a4d692e8c813b04dbae6323bc56003f5c3af862167a1d00a8bfe193dfda15d20a18a48bcbeac9313e29d6f2de35d20e621
DIST rb_libtorrent-1.0.8.tar.gz 2977324 SHA256 24498625d946b80b2269789fb666196240fe805a0b6417d83d1f4dd9ee5f9a7a SHA512 7ab98712225e19224c969fe4c6cd2f21f0aff3f5130dc1b3a0ea1b339b23b3cd303e76aeec9ac23e253c77865c60fd6623f7c8cd4e336c5a16fdf3d4627b88e2 WHIRLPOOL 23c3f84f304e642c7c25239a8a209d37afde41454f8688ef1b24c680d0d268e9163244dc06b973a49a8173f7e1cd7b7bf4f359fb89294cee5868060a64dbb2eb
111 changes: 111 additions & 0 deletions net-libs/rb_libtorrent/rb_libtorrent-1.0.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
PYTHON_REQ_USE="threads"
DISTUTILS_OPTIONAL=true
AUTOTOOLS_AUTORECONF=true

inherit autotools-utils multilib distutils-r1 versionator

MY_PV=$(replace_all_version_separators '_' )
S=${WORKDIR}/libtorrent-libtorrent-${MY_PV}

DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
HOMEPAGE="http://libtorrent.org"
SRC_URI="https://github.com/arvidn/libtorrent/archive/libtorrent-${MY_PV}.tar.gz -> rb_libtorrent-${PV}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc examples python ssl static-libs test"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

RDEPEND="
>=dev-libs/boost-1.53:=[threads]
sys-libs/zlib
examples? ( !net-p2p/mldonkey )
ssl? ( dev-libs/openssl:0= )
python? (
${PYTHON_DEPS}
dev-libs/boost:=[python,${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}
>=sys-devel/libtool-2.2"

RESTRICT="test"

AUTOTOOLS_IN_SOURCE_BUILD=1

src_prepare() {
chmod a-x docs/*.rst docs/*.htm* src/*.cpp include/libtorrent/*.hpp || die
./autotool.sh
}

src_configure() {
if use python_targets_python3_3 ;then
boost_py3="--with-boost-python=3.3"
elif use python_targets_python3_4 ;then
boost_py3="--with-boost-python=3.4"
elif use python_targets_python3_5 ;then
boost_py3="--with-boost-python=3.5"
else
boost_py3=""
fi

if use python_targets_python2_7 ;then
boost_py2="--with-boost-python=2.7"
else
boost_py2=""
fi

local myeconfargs=(
--disable-silent-rules # bug 441842
--with-boost-system=mt
$(use_enable debug)
$(use_enable test tests)
$(use_enable examples)
$(use_enable ssl encryption)
$(use_enable python python-binding)
$(usex debug "--enable-logging=verbose" "")
${boost_py3}
${boost_py2}
)

if use python ;then
python_setup
fi

autotools-utils_src_configure

if use python ;then
cd "${BUILD_DIR}"/bindings/python || die && \
distutils-r1_src_configure
fi
}

src_compile() {
autotools-utils_src_compile

if use python ;then
cd "${BUILD_DIR}"/bindings/python || die && \
distutils-r1_src_compile
fi
}

src_install() {
if use doc ;then
HTML_DOCS=( "${S}"/docs/. )
fi

autotools-utils_src_install

if use python ;then
cd "${BUILD_DIR}"/bindings/python || die && \
distutils-r1_src_install
fi
}

0 comments on commit 7284695

Please sign in to comment.