forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-mobilephone/kannel-sqlbox: bump to vn. 1.5.0
package pmasked for a while by pacho, then offer by user Travis Hansen to proxy maintian the package. Bup to vn. 1.5.0 source from ebuild by him, added to metadata.xml accordingly, closes the gentoo bug Gentoo bug: 493712 Package-Manager: portage-2.2.26
- Loading branch information
Ian Delaney
committed
Feb 6, 2016
1 parent
937a589
commit 72a3b80
Showing
3 changed files
with
78 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gateway-1.5.0.tar.gz 3469476 SHA256 9613fbf46ffaca322f3983a9b8a7579b135c54b8dd24cf715777da5ff50c5e53 SHA512 5bd35ff40e0f5882367f717e67104a0dc8703b5d6d95654e1268ded15cf6fac6366968b10adbe2eec22b3ac17fe3ae33b4142cd38f51fd3d75a56c8fe7653652 WHIRLPOOL d813da05f572e69c1619483c68a06f0587f8e191b1d71973fd9b63c22b8749169ae02963b48cfeae980aff1628f0b2c72a0ce9a82f4f7eecb5dc93cec0f2d2d7 | ||
DIST sqlbox-0.7.2.tar.gz 118074 SHA256 8d220ff4c1f026c91b2d5eb23d4b59468228f7d9d6cf8358989169dffeda1428 SHA512 0f8f565346e67f394a8f582c24ba149a62781e3a1b258ed5b137de8219aa264889986f2242409e20f75b42d754fdcb2f52a755c61ab6dc16ff6d102f6bd0dcc1 WHIRLPOOL b32397c2ff173e1dd134665f8fbea570ff3c54a20684853300a127a89b95ae94d5c511fcb7349fed393c884ca3129e45bc8d8cd92622f1b16fb24d73bdb57319 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2013 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel-sqlbox/kannel-sqlbox-0.7.2.ebuild,v 1.4 2013/07/25 01:53:56 creffett Exp $ | ||
|
||
EAPI="2" | ||
|
||
inherit eutils autotools | ||
|
||
DESCRIPTION="DB-Based Kannel Box for message queueing" | ||
HOMEPAGE="http://www.kannel.org/~aguerrieri/SqlBox/" | ||
SRC_URI="http://www.kannel.org/download/${PV}/gateway-${PV}.tar.gz" | ||
|
||
LICENSE="Apache-1.1 GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="ssl doc" | ||
|
||
RDEPEND="|| ( | ||
~app-mobilephone/kannel-${PV}[mysql] | ||
~app-mobilephone/kannel-${PV}[sqlite] | ||
~app-mobilephone/kannel-${PV}[postgres] | ||
) | ||
ssl? ( dev-libs/openssl )" | ||
DEPEND="${RDEPEND} | ||
doc? ( media-gfx/transfig | ||
app-text/jadetex | ||
app-text/docbook-dsssl-stylesheets | ||
app-text/docbook-sgml-dtd:3.1 )" | ||
|
||
S="${WORKDIR}/gateway-${PV}/addons/sqlbox/" | ||
|
||
src_configure() { | ||
LDFLAGS="" econf --docdir=/usr/share/doc/${PF} \ | ||
--without-ctlib \ | ||
--without-mssql \ | ||
$(use_enable ssl) \ | ||
$(use_enable doc docs) \ | ||
|| die "econf failed" | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install || die "failed emake install" | ||
|
||
if use doc; then | ||
emake doc/userguide.html || die "emake docs failed" | ||
dohtml doc/userguide.html || die "userguide.html not found" | ||
fi | ||
|
||
newinitd "${FILESDIR}"/kannel-sqlbox.initd kannel-sqlbox | ||
|
||
dodoc AUTHORS ChangeLog NEWS README | ||
insinto /etc/kannel | ||
newins example/sqlbox.conf.example sqlbox.conf.sample | ||
} | ||
|
||
pkg_postinst() { | ||
elog "Please view the following page for config information:" | ||
elog "http://www.kannel.org/pipermail/users/2006-October/000859.html" | ||
elog "" | ||
elog "In essence you need to do 3 things" | ||
elog "1. Create the database (tables will be automatically created by kannel)" | ||
elog "2. Point sqlbox to the smsbox-port in kannel [core] group" | ||
elog "3. Point smsbox to smsbox-port in sqlbox [sqlbox] group" | ||
elog "" | ||
elog "This literally puts sqlbox in between the bearerbox and smsbox" | ||
elog "for data storage into a database" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,15 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<longdescription>Sqlbox is a special Kannel box that sits between bearerbox and | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo Proxy Maintainers Project</name> | ||
</maintainer> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Travis Hansen</name> | ||
<description>Proxied maintainer; set to assignee in all bugs</description> | ||
</maintainer> | ||
<longdescription>Sqlbox is a special Kannel box that sits between bearerbox and | ||
smsbox and uses a database queue to store and forward messages.</longdescription> | ||
</pkgmetadata> |