Skip to content

Commit

Permalink
games-strategy/0ad: add 0.0.26_alpha
Browse files Browse the repository at this point in the history
Major changes are:
"
 - A new civilization: The Han
 - New campaign maps: Tarim basin and Yangtze.
 - Now units have acceleration.
 - Twenty-six new music tracks.
 - New and updated art.
"
quoting upstream release notes on:
https://play0ad.com/new-release-0-a-d-alpha-26-zhuangzi

Beside the bump itself following changes to the ebuild were made:
- Drop support for python 3.8 and 3.9, keeping 3.10.
- Re-structure comments about the signing and update the key used by
  upstream for alpha 26.
- Drop obsolete patches.
- Update the CHECKREQS_* filesizes.

Closes: https://bugs.gentoo.org/873829
Signed-off-by: Nils Freydank <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
holgersson32644 authored and thesamesam committed Oct 12, 2022
1 parent 8605766 commit 72c8ea0
Show file tree
Hide file tree
Showing 2 changed files with 272 additions and 0 deletions.
268 changes: 268 additions & 0 deletions games-strategy/0ad/0ad-0.0.26_alpha.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,268 @@
# Copyright 2014-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

WX_GTK_VER="3.0-gtk3"
# In alpha26 bundled spidermonkey-78.6.0 does not build with python 3.11.
PYTHON_COMPAT=( python3_10 )
inherit desktop toolchain-funcs multiprocessing python-any-r1 wxwidgets xdg

DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="https://play0ad.com/"
LICENSE="BitstreamVera CC-BY-SA-3.0 GPL-2 LGPL-2.1 LPPL-1.3c MIT ZLIB"
# Upstream signs releases with app-crypt/minisign which is not supported
# by IUSE="verify-sig", bug #783066. As a workaround the minisign key
# is hardcoded and verifed manually in this ebuild.
#
# The public key can be found upstream - last update was w/ alpha 26:
# https://trac.wildfiregames.com/wiki/VerifyingYourDownloads
MINISIGN_KEY="RWTWLbO12+ig3lUExIor3xd6DdZaYFEozn8Bu8nIzY3ImuRYQszIQyyy"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/0ad/0ad"
S="${WORKDIR}/${P}"
elif [[ ${PV} == *_pre* ]]; then
ZEROAD_GIT_REVISION="c7d07d3979f969b969211a5e5748fa775f6768a7"
SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${ZEROAD_GIT_REVISION}"
else
# Trailing whitespace for IUSE append below
IUSE="verify-sig "
MY_P="0ad-${PV/_/-}"
SRC_URI="
http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz
https://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz
verify-sig? (
http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz.minisig
http://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz.minisig
)
"
S="${WORKDIR}/${MY_P}"
fi
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE+="editor +lobby nvtt pch test"

RESTRICT="test"
CHECKREQS_DISK_BUILD="9000M" # 8795916 KiB (8.3 GiB) for alpha 26
CHECKREQS_DISK_USR="3500M" # 3555340 KiB (3.3 GiB)

# Premake adds '-s' to some LDFLAGS. Simply sed'ing it out leads to
# build and/or startup issues.
QA_PRESTRIPPED="/usr/lib64/0ad/libCollada.so /usr/bin/0ad"

# virtual/rust is for bundled SpiderMonkey.
# Build-time Python dependency is for SM, too.
BDEPEND="
${PYTHON_DEPS}
>=dev-util/premake-5.0.0_alpha12:5
virtual/pkgconfig
virtual/rust
test? ( dev-lang/perl )
"

# For IUSE="verify-sig", see note about SRC_URI block.
if [[ ( ${PV} != *9999 ) && ( ${PV} != *_p* ) ]]; then
BDEPEND+=" app-crypt/minisign"
fi

# Removed dependency on nvtt as we use the bundled one.
# bug #768930
DEPEND="
dev-libs/boost:=
dev-libs/icu:=
dev-libs/libfmt:0=
dev-libs/libsodium
dev-libs/libxml2
media-libs/libpng:0
media-libs/libsdl2[X,opengl,video]
media-libs/libvorbis
media-libs/openal
net-libs/enet:1.3
net-libs/miniupnpc:=
net-misc/curl
sys-libs/zlib
virtual/opengl
x11-libs/libX11
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
"
RDEPEND="
${DEPEND}
!games-strategy/0ad-data
"

PATCHES=(
"${FILESDIR}"/${PN}-0.0.24b_alpha-respect-tc.patch
"${FILESDIR}"/${PN}-0.0.25b_alpha-fix-setuptools.patch
)

pkg_setup() {
use editor && setup-wxwidgets

python-any-r1_pkg_setup
}

src_unpack() {
if [[ ( ${PV} != *9999 ) && ( ${PV} != *_p* ) ]]; then
if use verify-sig; then
elog "Verifying both signatures using app-crypt/minisign."
minisign -V \
-P "${MINISIGN_KEY}" \
-x "${DISTDIR}/${MY_P}-unix-build.tar.xz.minisig" \
-m "${DISTDIR}/${MY_P}-unix-build.tar.xz" \
|| die "Failed to verify engine distfile using minisign!"
minisign -V \
-P "${MINISIGN_KEY}" \
-x "${DISTDIR}/${MY_P}-unix-data.tar.xz.minisig" \
-m "${DISTDIR}/${MY_P}-unix-data.tar.xz" \
|| die "Failed to verify data distfile using minisign!"
fi
# Unpack manually until an eclass supports minisign and unpacks
# if signatures match.
default
else
# Unpack distfiles without checking as this is no official release.
default
fi
}

src_prepare() {
default

# SpiderMonkey's configure no longer recognises --build for
# the build tuple
sed -i -e "/--build/d" libraries/source/spidermonkey/build.sh || die

# Originally from 0ad-data
rm binaries/data/tools/fontbuilder/fonts/*.txt || die
}

src_configure() {
# 0AD uses premake:5 to generate the Makefiles, so let's
# 1. configure the configure args,
# 2. export some toolchain args,
# 3. configure premake args,
# 4. run premake5.
local myconf=(
--minimal-flags
$(usex nvtt "" "--without-nvtt")
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--bindir="/usr/bin"
--libdir="/usr/$(get_libdir)"/${PN}
--datadir="/usr/share/${PN}"
)

tc-export AR CC CXX RANLIB

local mypremakeargs=(
--outpath="../workspace/gcc"
--os=linux
--verbose
)

cd "${S}/build/premake" || die "Could not enter premake directory"

/usr/bin/premake5 "${mypremakeargs[@]}" "${myconf[@]}" gmake2 \
|| die "Premake failed"
}

src_compile() {
# Build 3rd party fcollada
einfo "Building bundled fcollada"
emake -C libraries/source/fcollada/src

# Build bundled NVTT
# nvtt is abandoned upstream and 0ad has forked it and added fixes.
# Use their copy. bug #768930
if use nvtt ; then
cd libraries/source/nvtt || die
elog "Building bundled NVTT (bug #768930)"
JOBS="-j$(makeopts_jobs)" ./build.sh || die "Failed to build bundled NVTT"
cd "${S}" || die
fi

# Build bundled SpiderMonkey
# We really can't use the system SpiderMonkey right now.
# Breakages occur even on minor bumps in upstream SM,
# e.g. bug #768840.
cd libraries/source/spidermonkey || die
elog "Building bundled SpiderMonkey (bug #768840)"
XARGS="${EPREFIX}/usr/bin/xargs" \
JOBS="-j$(makeopts_jobs)" \
./build.sh \
|| die "Failed to build bundled SpiderMonkey"

cd "${S}" || die

# Build 0ad itself!
elog "Building 0ad"
JOBS="-j$(makeopts_jobs)" emake -C build/workspace/gcc verbose=1

# Build assets
# (We only do this if we're using a snapshot/non-release)
# See bug #771147 (comment 3) and the old 0ad-data ebuild
# Warning: fragile!
if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
# source/lib/sysdep/os/linux/ldbg.cpp:debug_SetThreadName() tries to open /proc/self/task/${TID}/comm for writing.
addpredict /proc/self/task

# Based on source/tools/dist/build-archives.sh used by source/tools/dist/build.sh.
local archivebuild_input archivebuild_output mod_name
for archivebuild_input in binaries/data/mods/[A-Za-z0-9]*; do
mod_name="${archivebuild_input##*/}"
archivebuild_output="archives/${mod_name}"

mkdir -p "${archivebuild_output}" || die

einfo pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip"
LD_LIBRARY_PATH="binaries/system" binaries/system/pyrogenesis \
-archivebuild="${archivebuild_input}" \
-archivebuild-output="${archivebuild_output}/${mod_name}.zip" \
|| die "Failed to build assets"

if [[ -f "${archivebuild_input}/mod.json" ]]; then
cp "${archivebuild_input}/mod.json" "${archivebuild_output}" || die
fi

rm -r "${archivebuild_input}" || die
mv "${archivebuild_output}" "${archivebuild_input}" || die
done

# Based on source/tools/dist/build-unix-win32.sh used by source/tools/dist/build.sh.
rm binaries/data/config/dev.cfg || die
rm -r binaries/data/mods/_test.* || die
fi
}

src_test() {
cd binaries/system || die
./test -libdir "${S}/binaries/system" || die "Failed tests"
}

src_install() {
newbin binaries/system/pyrogenesis 0ad
use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor

# Merged from 0ad-data
# bug #771147 (comment 3)
insinto /usr/share/${PN}
doins -r binaries/data/{l10n,config,mods,tools}

# Install bundled SpiderMonkey and nvtt
# bug #771147 (comment 1)
exeinto /usr/$(get_libdir)/${PN}
doexe binaries/system/{libCollada,libmozjs78-ps-release}.so

use nvtt && doexe binaries/system/{libnvtt,libnvcore,libnvimage,libnvmath}.so
use editor && doexe binaries/system/libAtlasUI.so

dodoc binaries/system/readme.txt
doicon -s 128 build/resources/${PN}.png
make_desktop_entry ${PN}
}
4 changes: 4 additions & 0 deletions games-strategy/0ad/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,7 @@ DIST 0ad-0.0.25b-alpha-unix-build.tar.xz 75579956 BLAKE2B 674d69d625137709a186f9
DIST 0ad-0.0.25b-alpha-unix-build.tar.xz.minisig 327 BLAKE2B 547a7a1c8a83167fa40976efb2efaf691fc5434eb1be227b481a70d308381b20dcdc90bb4652e190f8e329fb33cc19ebbaab43977329f8971e49436f7f1ce636 SHA512 9d6a235ea50183e1db16f4bf2dc59af9042a52e4e18ccd0c34c481a7e9021f19e2bc370e594aa97911bb7ca33bcc5ebe23a4b206cd74357060371ca06b6010d2
DIST 0ad-0.0.25b-alpha-unix-data.tar.xz 1249684600 BLAKE2B d77546ba9d21b512f106645c07fa92ecc343e0a01d9a70a83f2a2b3ade912e72d095982f7d4c4cd64e18fb71a67a01c419763744dd4cad1e8c081e5f77ec17c9 SHA512 d6bbe484acb7fbd507d303f5c75f8a2ccbaf8fe9dd30ff408b082f170bfd96eb9235db1b710c15656ef465b44fa5597679a694515e0c153a35fe24c0915f29f1
DIST 0ad-0.0.25b-alpha-unix-data.tar.xz.minisig 326 BLAKE2B 41975d4c4369780bd36edef448ab928c91ece0d60ddad04fbccd1da0ed5068b56c86fd57708c6158277c5db9faadc768f5e455d97fe5ae3c30a7522005c374e6 SHA512 ad3ef78b785db9eb37d547a86d2bf274e0b6635118a9c512d013adc45e4a0f071b86f0fb5bf696631596e0713b2de153b0ad245cbba86beb3ea153036178b07e
DIST 0ad-0.0.26-alpha-unix-build.tar.xz 75599800 BLAKE2B ddd589840b0dacee2377ff4e5624f69646b92da4217015d788c6abec097578e44aee6641b6a6945d15f50d8e50673a1d44587c2faf02278d981a0ed30c950214 SHA512 aaf647d5d8454c244015d2a198beeaaebc571a5bc96446f3acff8dbd05f9843029c500bf4162651a5e1fcdb42bd5fb5b4f5c512c78372479fbd8565dd093f272
DIST 0ad-0.0.26-alpha-unix-build.tar.xz.minisig 333 BLAKE2B 9f3146abda592fe6ab9433f6ee30060bcd4c5b594e00cb3fccc0aebb74652f3bc2ddd7b19a296da7ca13126ea9cc0337750f859e24f46adfcb84272bd2cce452 SHA512 eda542c1c363c7c0e6b235e6d8dfbd96d1c1e7cfca408b7215cf247b96c9f42b8bc206bbb4dd48dc41ee373db17d4a76cba940e454840dc41638dd572c580850
DIST 0ad-0.0.26-alpha-unix-data.tar.xz 1351511480 BLAKE2B 2f483593b79a6ae87d7582625e89c890cfcf4ad7116348b184dae6c47a814d95a7b9f3018cb79e8f024a61c647abd39d6faf5ad3d3fcbb0c7a0583d0479d9b18 SHA512 8fe29fce68737d5b7001c8c2a7198766583b22556129cd2d927823da9b2c58f224fb1207f35bd03abea9380cf24d00ab6257b0dba86ce3ad1f357d7006f051d6
DIST 0ad-0.0.26-alpha-unix-data.tar.xz.minisig 332 BLAKE2B fb4ec1bcabad79052a5e391557623ad61234d4948ec919d9a79011037855b6c7c94445d8f1667f1725bf80d15d66d1aa32c4e2b259831fbe088fe79e800515b3 SHA512 6dd55dda4e6cd52642b331aa571bc4ccfe30a33ad12a5d3ccf51c708d05dd74bf3234ca722c2a6501ba797bc1f8fa7c7aeb4d836dc4792bfd0c6bbccdc2c1237

0 comments on commit 72c8ea0

Please sign in to comment.