forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x11-libs/libva-intel-driver: Bump to 1.8.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libva-intel-driver-1.7.3.tar.bz2 1547040 SHA256 76ad37d9fd5ae23d8ce6052d50b5e6438a8df9e769b13fe34b771cd453f4f937 SHA512 90567b94e3373287b1b5fe776e291dfd33577bbe5e4ec1bee359c88544c9c17bbae2aac511ff3d704d7b99b19fbc908c9a38ebbd3162e3625c86c416142390e6 WHIRLPOOL a585d1e800a45fe6dc8ec1bb244452ac195173051e15adb2ec33224238cf7e93f686a98c400bf98d73153a3080d37c15e4c09bd9da4882a211374a61df395f66 | ||
DIST libva-intel-driver-1.8.0.tar.gz 2308240 SHA256 45a38641f3ddbd43d9c053bfd9cb809ecb2d5f5227f0e3c1c5a8d51dccf81b35 SHA512 fbf68ad5f7558366dadf6e8d834ed89665e86167676ca72fdca218023f5709b0bdf1b124f11ed3f7c10b60741a2574a8ea7c3e5607a6727d3b9cc2ed44981542 WHIRLPOOL 9907ba61a3ae7fb512a34c20a2e53a8e309b772a3cea6c898e4caec376646c27db80983ebbac1da1ab25da7e7c917e81379871ee91f58889a46c5d083175efee | ||
DIST libva-intel-driver-1.8.1.tar.gz 2309572 SHA256 0c591b31dce558f14d2be8a9ed0620704499159b7fe65b830e914b027fd73d58 SHA512 a7c414ce32f1724acf62dd67099e5b0642aae880434232adb26f228037ccd8f070a0d836a541841992513c2945520bf2e4dd70309d8d551a892d845303489baa WHIRLPOOL 8d9ed67fe72d21c4ffcd9e0f98274be8a5e0296c85184146ee3d19d57f99330d2a57729ccd22997e5ea9f3515babf4d97a7eb84273febf0d9a80af56785b9de9 | ||
DIST libva-intel-driver-1.8.2.tar.gz 2309998 SHA256 8c7bba21abbb63cdbd3f5e7fb3b4ce9a2f9b7cdf22018f38e4cd7815c5e98793 SHA512 047362e2ca301e01db8bd73450595c91fd4da36da4737be2fe7ba32086a0ead3443e9247ae84f87034c9ded3f046c314af0d1baab8930bb03b77f22ad1fac9f0 WHIRLPOOL 401e64184c9acad41fc8bf2be3fdf0d9c1443ed71fa55b5336d5a924d85b3905d1077b5f5c732dad11017680f13f6f3046aaf95f9c3351bc515aa63d85370855 |
56 changes: 56 additions & 0 deletions
56
x11-libs/libva-intel-driver/libva-intel-driver-1.8.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
SCM="" | ||
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild | ||
SCM=git-r3 | ||
EGIT_BRANCH=master | ||
EGIT_REPO_URI="https://github.com/01org/intel-vaapi-driver" | ||
fi | ||
|
||
AUTOTOOLS_AUTORECONF="yes" | ||
inherit autotools-multilib ${SCM} | ||
|
||
DESCRIPTION="HW video decode support for Intel integrated graphics" | ||
HOMEPAGE="https://github.com/01org/intel-vaapi-driver" | ||
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild | ||
SRC_URI="" | ||
else | ||
SRC_URI="https://github.com/01org/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/intel-vaapi-driver-${PV}" | ||
fi | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
if [ "${PV%9999}" = "${PV}" ] ; then | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
else | ||
KEYWORDS="" | ||
fi | ||
IUSE="+drm wayland X" | ||
|
||
RDEPEND=">=x11-libs/libva-1.8.0[X?,wayland?,drm?,${MULTILIB_USEDEP}] | ||
>=x11-libs/libdrm-2.4.46[video_cards_intel,${MULTILIB_USEDEP}] | ||
wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
DOCS=( AUTHORS NEWS README ) | ||
AUTOTOOLS_PRUNE_LIBTOOL_FILES="all" | ||
|
||
src_prepare() { | ||
sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die | ||
autotools-multilib_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
local myeconfargs=( | ||
$(use_enable drm) | ||
$(use_enable wayland) | ||
$(use_enable X x11) | ||
) | ||
autotools-utils_src_configure | ||
} |