Skip to content

Commit

Permalink
dev-ruby/childprocess: add 4.0.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Jun 19, 2020
1 parent b1820f5 commit 731d7f3
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/childprocess/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST childprocess-0.9.0.gem 32768 BLAKE2B cb836c2cc3f9d6bda1db88aec8692499dae2a3
DIST childprocess-1.0.1.gem 34816 BLAKE2B 54b1db5bfa8829eeaa923f9e7be88183058d0c4f3ad7474b96199b486bc12f7035a0a1eb9858ce9e8e4aa73eb34fe81e734b206851ca744abbcbb6bb32e4d1df SHA512 efe61096dd09f6278582763692104fcc3beacfc96065372afdee355b68ef6ed498baf855f911d2a0b3a186d978d6d737519ae189064293af2d756a7356dad30d
DIST childprocess-2.0.0.gem 34816 BLAKE2B 8c25d861e20296f322c94886f39178c099ababf1c0f1d249cb838e253563d4d9b6f90b433cec31c4288883516281faa3f2aaaafaacf6f2b4e4427e8270488459 SHA512 104f031cb878ed3713b3c326ba0071a8cb2fb5d4e536c5fd7d0dcdcf23e343e46077737d746ffdec7d26accc35b91ab9e496afcae38ee91e0c2272ca39246199
DIST childprocess-3.0.0.gem 33792 BLAKE2B 7927e29efdff3fe5ad26fdf8ff5d55328412c89d442d3ad34fd44b642a91edf5cde3a271f2f7929a6365a3a740212f3f1364867ecec09c0d5c3846466922cf82 SHA512 56aa9303f1a88d57d0928f9c7177291a115736a5989e30bdabfb0b7fa1e6b02e42e45bf5e0498efc5ab9bb5f58a44004ed56bda61d95ca9a8d8df156b9f30ada
DIST childprocess-4.0.0.gem 34304 BLAKE2B f27188ae722a8a3fd1279916f8f364365778053dd3c9fe2510abe35d60df4be430c9988ba5575acb1864f55c4c9130cb300328f0915d808e1760ec2b3bd7350c SHA512 89ea5f9d437ac2e5d246fc849002a5d14fba2907b5055cbf12a7ec89545bc3daa531dcc0217ebc7a7d88ee21798e2886a899679f6d25f2e664390752ab32dbe2
40 changes: 40 additions & 0 deletions dev-ruby/childprocess/childprocess-4.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby25 ruby26 ruby27"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_EXTRADOC="README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="Solution for controlling external programs running in the background"
HOMEPAGE="https://github.com/jarib/childprocess"

LICENSE="MIT"
SLOT="2"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE=""

ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"

all_ruby_prepare() {
# Remove bundler support
rm Gemfile || die
sed -i -e "/[Bb]undler/d" Rakefile || die
sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
}

each_ruby_prepare() {
sed -i -e "s:'ruby':'"${RUBY}"':" spec/childprocess_spec.rb || die
}

each_ruby_test() {
RUBYLIB=lib RSPEC_VERSION=3 ruby-ng_rspec
}

0 comments on commit 731d7f3

Please sign in to comment.