Skip to content

Commit

Permalink
app-office/scribus: in 1.6.1 squashed findhyphen patches and backport…
Browse files Browse the repository at this point in the history
…ed some patches from live

Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
fordfrog committed Jan 14, 2024
1 parent 142e523 commit 73525ea
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 17 deletions.
69 changes: 69 additions & 0 deletions app-office/scribus/files/scribus-1.6.1-findhyphen.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
--- a/CMakeLists_Dependencies.cmake
+++ b/CMakeLists_Dependencies.cmake
@@ -1,6 +1,16 @@
##############################################################################################################
########## Find Dependencies ##########

+#<<HYPHEN for Hyphenation support
+find_package(HYPHEN)
+if(HYPHEN_FOUND)
+ message("System Hyphen Found OK")
+ set(HAVE_HYPHEN ON)
+else()
+ message("Hyphen or its developer libraries NOT found - using bundled Hyphen instead")
+endif()
+#>>HYPHEN for Hyphenation support
+
#<<PoDoFo for AI PDF import
option(WITH_PODOFO "Enable support for PDF embedded in AI" ON)
if (WITH_PODOFO)
--- a/scribus/CMakeLists.txt
+++ b/scribus/CMakeLists.txt
@@ -585,7 +585,9 @@ set(SCRIBUS_SOURCES
${SCRIBUS_GMAGICK_SRC}
)

-if(NOT HAVE_HYPHEN)
+if(HAVE_HYPHEN)
+ include_directories(${HYPHEN_INCLUDE_DIR})
+else()
include_directories(third_party/hyphen)
set(SCRIBUS_SOURCES
${SCRIBUS_SOURCES}
@@ -676,12 +678,6 @@ if(HAVE_PODOFO)

endif()

-if(HAVE_HYPHEN)
- target_link_libraries(${EXE_NAME} PRIVATE
- ${HYPHEN_LIBRARY}
- )
-endif()
-

if(GESTURE_FRAME_PREVIEW)
message(STATUS "Enable gesture frame preview [experimental]")
@@ -741,6 +737,12 @@ if(WANT_PCH)
target_precompile_headers(${EXE_NAME} PRIVATE scribus_pch.h)
endif()

+if(HAVE_HYPHEN)
+ target_link_libraries(${EXE_NAME} PRIVATE
+ ${HYPHEN_LIBRARY}
+ )
+endif()
+
if(WIN32)
set_target_properties(${EXE_NAME}
PROPERTIES
--- a/scribus/hyphenator.h
+++ b/scribus/hyphenator.h
@@ -13,7 +13,7 @@ for which a new license (GPL+exception) is in place.
#include <QSet>

#include "scribusapi.h"
-#include "third_party/hyphen/hyphen.h"
+#include <hyphen.h>

class ScribusDoc;
class ScribusMainWindow;
Original file line number Diff line number Diff line change
Expand Up @@ -72,31 +72,18 @@ BDEPEND="
"

PATCHES=(
# non(?)-upstreamable
"${FILESDIR}"/${PN}-1.5.8-cmake.patch # bug 886251
"${FILESDIR}"/${PN}-1.5.3-fpic.patch
"${FILESDIR}"/${PN}-1.5.8-findhyphen-1.patch
"${FILESDIR}"/${PN}-1.5.6-findhyphen.patch
"${FILESDIR}"/${PN}-1.6.1-findhyphen.patch
"${FILESDIR}"/${PN}-1.7.0-remove-hello-world-test.patch
"${FILESDIR}"/${PN}-1.7.0-fix-icon-version.patch
)

src_prepare() {
cmake_src_prepare

# for safety remove files that we patched out
rm -r scribus/third_party/hyphen || die

sed \
-e "/^\s*unzip\.[ch]/d" \
-e "/^\s*ioapi\.[ch]/d" \
-i scribus/CMakeLists.txt Scribus.pro || die
rm scribus/ioapi.[ch] || die

sed \
-e 's:\(${CMAKE_INSTALL_PREFIX}\):./\1:g' \
-i resources/templates/CMakeLists.txt || die

sed \
-e "/^add_subdirectory(ui\/qml)/s/^/#DONT/" \
-i scribus/CMakeLists.txt || die # nothing but a bogus Hello World test
}

src_configure() {
Expand Down

0 comments on commit 73525ea

Please sign in to comment.