Skip to content

Commit

Permalink
gnome-extra/cjs: 4.8.2 version bump
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/757708
Bug: https://bugs.gentoo.org/649534
Closes: https://bugs.gentoo.org/761852
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Signed-off-by: Matthew S. Turnbull <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
SparkyBluefang authored and juippis committed Jan 24, 2021
1 parent e747f84 commit 7379e01
Show file tree
Hide file tree
Showing 6 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/cjs/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cjs-4.6.0.tar.gz 463060 BLAKE2B 466f807539ea95eece8b468287582f2c085ce86a63cf37ed1489f6ed20c98dfcb7028c7679102526009b71aba7d737f6f56c9544bc926fbf5a0be540afeaee53 SHA512 b7b457b43b756918670c9acc1064fc5b424d7bb7ab826ec207595c98159f407411ceb6d3043d305570f21f7675e1b699d7e95466688835034e178e079e118dfe
DIST cjs-4.8.2.tar.gz 600711 BLAKE2B d1506e599c05301083479df4145d3177c9cbb057d3ed260e9744994da70fe392eb2cd872dc00b1ef6269efe9442e32e16878ba975f57f1abc35851cb15e7bb97 SHA512 c607198847a3229443bbfa6906b05036295b6d7f95d3b355780b28e69382407a8f6ef5f637f411fbf2ae474c4c7c5f68f64fec6dd7a2e7f944945927f5efac91
65 changes: 65 additions & 0 deletions gnome-extra/cjs/cjs-4.8.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson pax-utils virtualx

DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
SLOT="0"
IUSE="+cairo examples gtk readline sysprof test"
KEYWORDS="~amd64 ~arm64 ~x86"

RDEPEND="
dev-lang/spidermonkey:78
>=dev-libs/glib-2.58.0:2
>=dev-libs/gobject-introspection-1.58.3:=
>=dev-libs/libffi-3.2.1:0=
cairo? ( x11-libs/cairo[glib,X] )
readline? ( sys-libs/readline:0= )
"
DEPEND="
${RDEPEND}
sysprof? ( >=dev-util/sysprof-capture-3.38.1:4 )
test? (
sys-apps/dbus
gtk? ( x11-libs/gtk+:3[introspection] )
)
"
BDEPEND="
virtual/pkgconfig
"

src_configure() {
local emesonargs=(
$(meson_feature cairo)
$(meson_feature readline)
$(meson_feature sysprof profiler)
-Dinstalled_tests=false
$(meson_use !test skip_dbus_tests)
$(meson_use !test skip_gtk_tests)
)
meson_src_configure
}

src_test() {
virtx meson_src_test
}

src_install() {
meson_src_install

if use examples; then
docinto examples
dodoc "${S}"/examples/*
fi

# Required for cjs-console to run correctly on PaX systems
pax-mark mr "${ED}/usr/bin/cjs-console"
}
3 changes: 3 additions & 0 deletions gnome-extra/cjs/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,4 +12,7 @@
<upstream>
<remote-id type="github">linuxmint/cjs</remote-id>
</upstream>
<use>
<flag name="sysprof">Enable profiling data capture support using <pkg>dev-util/sysprof-capture</pkg></flag>
</use>
</pkgmetadata>
1 change: 1 addition & 0 deletions profiles/arch/amd64/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -90,6 +90,7 @@ www-client/firefox -eme-free
x11-wm/mutter -sysprof
dev-libs/gjs -sysprof
dev-libs/glib -sysprof
gnome-extra/cjs -sysprof
x11-libs/gtk+ -sysprof

# Andreas Sturmlechner <[email protected]> (2020-02-26)
Expand Down
1 change: 1 addition & 0 deletions profiles/arch/base/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -67,6 +67,7 @@ sys-libs/glibc static-pie
x11-wm/mutter sysprof
dev-libs/gjs sysprof
dev-libs/glib sysprof
gnome-extra/cjs sysprof
x11-libs/gtk+ sysprof

# Andreas Sturmlechner <[email protected]> (2020-02-26)
Expand Down
1 change: 1 addition & 0 deletions profiles/arch/x86/package.use.mask
Original file line number Diff line number Diff line change
Expand Up @@ -102,6 +102,7 @@ www-client/firefox -eme-free
x11-wm/mutter -sysprof
dev-libs/gjs -sysprof
dev-libs/glib -sysprof
gnome-extra/cjs -sysprof
x11-libs/gtk+ -sysprof

# Andreas Sturmlechner <[email protected]> (2020-02-26)
Expand Down

0 comments on commit 7379e01

Please sign in to comment.