Skip to content

Commit

Permalink
games-fps/blackshades: port to EAPI 7, eutils--
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 4, 2021
1 parent f90239d commit 737cdff
Showing 1 changed file with 21 additions and 6 deletions.
27 changes: 21 additions & 6 deletions games-fps/blackshades/blackshades-20070723-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,19 +1,20 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils
EAPI=7

inherit desktop toolchain-funcs

DESCRIPTION="You control a psychic bodyguard, and try to protect the VIP"
HOMEPAGE="http://www.wolfire.com/blackshades.html
http://www.icculus.org/blackshades/"
SRC_URI="http://filesingularity.timedoctor.org/Textures.tar.bz2
mirror://gentoo/${P}.tar.bz2"
S="${WORKDIR}"/${PN}

LICENSE="blackshades"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
media-libs/freealut
Expand All @@ -24,8 +25,6 @@ DEPEND="
virtual/opengl"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${PN}

PATCHES=(
"${FILESDIR}"/${PN}-datadir.patch
)
Expand All @@ -36,25 +35,41 @@ src_prepare() {
rm -rf Data/Textures || die
rm -f ../Textures/{,Blood/}._* || die
mv -f ../Textures Data || die "mv failed"

sed -i \
-e "s/-O2 \(-Wall\) -g/${CXXFLAGS} \1/" \
-e "/^LINKER/s:$: ${LDFLAGS}:" \
Makefile \
|| die "sed Makefile failed"

sed -i \
-e "s/CC := gcc/CC ?= gcc/" \
-e "s/CXX := g++/CXX ?= g++/" \
-e "s/LINKER := g++/LINKER ?= g++/" \
-e "s/LDFLAGS := /LDFLAGS := ${LDFLAGS} /" \
Makefile || die

sed -i "s:@DATADIR@:/usr/share/${PN}:" \
Source/Main.cpp \
|| die "sed Main.cpp failed"
}

src_compile() {
tc-export CC CXX

export LINKER="${CXX}"

emake bindir
emake
}

src_install() {
newbin objs/blackshades ${PN}

insinto /usr/share/${PN}
doins -r Data

dodoc IF_THIS_IS_A_README_YOU_HAVE_WON Readme TODO uDevGame_Readme

make_desktop_entry ${PN} "Black Shades"
}

0 comments on commit 737cdff

Please sign in to comment.