Skip to content

Commit

Permalink
dev-lang/rakudo: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Jun 8, 2020
1 parent d75d396 commit 737ead0
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/rakudo/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST rakudo-2019.03.tar.gz 4128971 BLAKE2B 0b1eeb4ebcf7abdbc477cf1b64a6b1f85821e03a953b71aca53ac4fdc88bf3c8df0ecbc95c687ab6686a4cdd4ddb6c7caf89c97ed407d4c0b45203b65397aa11 SHA512 c6b77bbc7d806a399adccccc98c273063c90756967769cd288a161317cc81151dff4feb1219b534aeec5d60e4344fd1f7e166cfc3b90389fd550b2862178f447
DIST rakudo-2019.11.tar.gz 4651014 BLAKE2B 4e95b834d074efcf515e4b1e6776ef4a34398dcc4536e315b759dcb56565e64e19e2cf513b97b85974639b3c3b9968129a6781bbafb37fded98f108c32d06ceb SHA512 6d058fe1e1630023f14ac910ade75f22b963f9eb8e524a8c9006a6df8e0764f283f2c8bd4af4a303b2151e6078fccd8b3cb6c388f70e38d6e9465505eefafdb4
DIST rakudo-2020.05.1.tar.gz 4802231 BLAKE2B ead9db815bb29d78f4a92157ff65e43c28f19e52e19f3972783b2a8d6c1814576c30d5b612e12f1500a7ae436c66b70d9774aa69f2ea421cc4382341cbd40498 SHA512 20d0818fc9f13693f098c41799cceb39e21442ac652993981fcab1fc1c7158058b42746f3ca3b145938fb6adb03f045f4784e77bf11da672c5908d0a5a36975f
73 changes: 73 additions & 0 deletions dev-lang/rakudo/rakudo-2020.05.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit java-pkg-opt-2

DESCRIPTION="A compiler for the Perl 6 programming language"
HOMEPAGE="https://rakudo.org"

if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
inherit git-r3
KEYWORDS=""
else
SRC_URI="https://rakudo.org/dl/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="Artistic-2"
SLOT="0"
# TODO: add USE="javascript" once that's usable in nqp
IUSE="clang java +moar test"
RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( java moar )"

CDEPEND="~dev-lang/nqp-${PV/.1/}:${SLOT}=[java?,moar?,clang=]"
RDEPEND="${CDEPEND}
java? ( >=virtual/jre-1.7 )"
DEPEND="${CDEPEND}
clang? ( sys-devel/clang )
java? ( >=virtual/jdk-1.7 )
>=dev-lang/perl-5.10"

pkg_pretend() {
if has_version dev-lang/rakudo; then
ewarn "Rakudo is known to fail compilation/installation with Rakudo"
ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
ewarn "then do a new installation."
ewarn "(see Bug #584394)"
fi
}

src_configure() {
local backends
use moar && backends+="moar,"
use java && backends+="jvm"

local myargs=(
"--prefix=/usr"
"--sysroot=/"
"--sdkroot=/"
"--backends=${backends}"
)

perl Configure.pl "${myargs[@]}" || die

if use java; then
NQP=$(java-pkg_getjars --with-dependencies nqp)
fi
}

src_compile() {
emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
}

src_install() {
emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
}

src_test() {
RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
}

0 comments on commit 737ead0

Please sign in to comment.