forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mate-base/mate-control-center: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <[email protected]> Package-Manager: Portage-2.3.62, Repoman-2.3.11
- Loading branch information
Showing
2 changed files
with
72 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST mate-control-center-1.18.2.tar.xz 1351644 BLAKE2B 30c093b11f3cbf32e3590368001d8d929b8f611c4efd58f6332a70905ef028b8e573e41cbb20b5342ad2b0f459327d9665c4db77104bf49b2b8be4935adc232c SHA512 0acc6d775aa26dd0265ddab80317b2ddd2f027394b55574e29e6ad233b8711bc0984803f76f2cbaeed2bfd2b4397cd5143d5540908f5078080a1749290dac7ab | ||
DIST mate-control-center-1.22.0.tar.xz 1524084 BLAKE2B e0d7beb9fb358d6e60d6847fb6ee9e295793f856d25b0acf865efc360eefd446fa3f5a22d51121cd0fe675e01509b2612602587d4583b8835ec8e7157b795923 SHA512 3b2b88458848862a4c819d54104e9394817b29feb3d05117fe69441023ec5e6c922012395f24b5f70c9f9dbf6f8044f769840ec9996b1495441c4cb690f68371 |
71 changes: 71 additions & 0 deletions
71
mate-base/mate-control-center/mate-control-center-1.22.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
MATE_LA_PUNT="yes" | ||
|
||
inherit mate | ||
|
||
if [[ ${PV} != 9999 ]]; then | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
fi | ||
|
||
DESCRIPTION="The MATE Desktop configuration tool" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
IUSE="appindicator debug" | ||
|
||
COMMON_DEPEND=" | ||
dev-libs/atk | ||
>=dev-libs/dbus-glib-0.73 | ||
>=dev-libs/glib-2.50:2 | ||
dev-libs/libxml2:2 | ||
>=gnome-base/dconf-0.13.4 | ||
>=gnome-base/librsvg-2.0:2 | ||
>=mate-base/libmatekbd-1.17.0 | ||
>=mate-base/mate-desktop-1.21.2 | ||
>=mate-base/caja-1.20.0 | ||
>=mate-base/mate-menus-1.1.0 | ||
>=mate-base/mate-settings-daemon-1.21.2 | ||
>=media-libs/fontconfig-1:1.0 | ||
media-libs/freetype:2 | ||
media-libs/libcanberra:0[gtk3] | ||
>=sys-apps/dbus-1 | ||
x11-apps/xmodmap | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
>=x11-libs/gtk+-3.22:3 | ||
x11-libs/libX11 | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXcursor | ||
x11-libs/libXext | ||
>=x11-libs/libXi-1.5 | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
x11-libs/libXxf86misc | ||
>=x11-libs/libxklavier-4 | ||
x11-libs/pango | ||
>=x11-wm/marco-1.17.0 | ||
virtual/libintl | ||
appindicator? ( dev-libs/libappindicator:3 )" | ||
|
||
RDEPEND="${COMMON_DEPEND}" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
app-text/rarian | ||
>=app-text/scrollkeeper-dtd-1:1.0 | ||
app-text/yelp-tools | ||
dev-util/desktop-file-utils | ||
>=dev-util/intltool-0.50.1 | ||
sys-devel/gettext:* | ||
x11-base/xorg-proto | ||
virtual/pkgconfig:*" | ||
|
||
src_configure() { | ||
mate_src_configure \ | ||
--disable-update-mimedb \ | ||
$(use_enable appindicator) \ | ||
$(use_enable debug) | ||
} |