Skip to content

Commit

Permalink
app-arch/dpkg: Version 1.19.1.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Sep 29, 2018
1 parent a1c6db6 commit 73b8142
Show file tree
Hide file tree
Showing 3 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/dpkg/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST dpkg_1.19.0.5.tar.xz 4557428 BLAKE2B 99c31705bfad1cfa024366c788264f4e747a7143f87c581730797975303c1054003e41fd65ecf80df1dc053ba87c0e8449ec574ddcb158228b41ae57a23db18f SHA512 60d7198ffe6ea759c30ad82143b3107d41ce59224b853cb5a7beb79af0de6ba6a69414c365e6b3555a0a9c60e3cf9b543a3a448d80a734be38ccecb77ae963a9
DIST dpkg_1.19.1.tar.xz 4600848 BLAKE2B daadc95f0f66312e6012a5c9ce053dba055d87f766d8e9b9e99ed3eed59e83616b89cb2324fc61205bf4e22388cc0f9f62d191cbdd858250a50f7c6d141adf7d SHA512 d2c745f8cc3db94be15ce3ef74f9317768b316d9bb96aac2c681c2f47433524774e0c2d5ff3daf6e7cc779e5ffc4ce96783de12802f32dab1d72022786ca6c20
90 changes: 90 additions & 0 deletions app-arch/dpkg/dpkg-1.19.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils multilib autotools toolchain-funcs

DESCRIPTION="Package maintenance system for Debian"
HOMEPAGE="https://packages.qa.debian.org/dpkg"
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
IUSE="+bzip2 libmd +lzma nls selinux static-libs test unicode +update-alternatives +zlib"

RDEPEND="
>=dev-lang/perl-5.14.2:=
bzip2? ( app-arch/bzip2 )
libmd? ( app-crypt/libmd )
lzma? ( app-arch/xz-utils )
selinux? ( sys-libs/libselinux )
zlib? ( >=sys-libs/zlib-1.1.4 )
"
DEPEND="
${RDEPEND}
app-arch/xz-utils
sys-devel/flex
virtual/pkgconfig
nls? (
app-text/po4a
>=sys-devel/gettext-0.18.2
)
test? (
dev-perl/IO-String
dev-perl/Test-Pod
virtual/perl-Test-Harness
)
"
DOCS=(
ChangeLog
THANKS
TODO
)
PATCHES=(
"${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
"${FILESDIR}"/${PN}-1.18.12-flags.patch
"${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
)

src_prepare() {
use nls && strip-linguas -i po

default

eautoreconf
}

src_configure() {
tc-export CC
econf \
$(use_enable nls) \
$(use_enable static-libs static) \
$(use_enable unicode) \
$(use_enable update-alternatives) \
$(use_with bzip2 libbz2) \
$(use_with libmd) \
$(use_with lzma liblzma) \
$(use_with selinux libselinux) \
$(use_with zlib libz) \
--disable-compiler-warnings \
--disable-dselect \
--disable-silent-rules \
--disable-start-stop-daemon \
--localstatedir="${EPREFIX}"/var
}

src_compile() {
emake AR=$(tc-getAR)
}

src_install() {
default

keepdir \
/usr/$(get_libdir)/db/methods/{mnt,floppy,disk} \
/var/lib/dpkg/{alternatives,info,parts,updates}
# /usr/$(get_libdir)/db/{alternatives,info,parts,updates} \

prune_libtool_files
}
1 change: 1 addition & 0 deletions app-arch/dpkg/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
<name>Gentoo Debian Tools Project</name>
</maintainer>
<use>
<flag name="libmd">Use <pkg>app-crypt/libmd</pkg> library for message digest functions</flag>
<flag name="update-alternatives">Install update-alternatives</flag>
</use>
</pkgmetadata>

0 comments on commit 73b8142

Please sign in to comment.