Skip to content

Commit

Permalink
app-office/gnumeric: Version bump to 1.12.47
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Jun 7, 2020
1 parent d673772 commit 73dbfde
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/gnumeric/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gnumeric-1.12.46.tar.xz 18282960 BLAKE2B f10fd8620dd2b865a4205b93f68ba78a07b94e72a147692bf875747cb8f128c54fad38e33162770d71422aed659f77b156679ca2f65836530c02b56cc2351ac6 SHA512 b3b3befe79f3ec8db6d7d9c80a1eed5293f5c0a9ca1d8dd131320eb031952b296147c51df1c775c6f9a0c466912e5523360373ee0b6e453e928929394ab517ea
DIST gnumeric-1.12.47.tar.xz 18309764 BLAKE2B 8b800a6749d208a445abfc7189618abb20907118f274b313cf81436ab3665d50edeab4c49b03adea505448138bd32b8d3efcd041eba54342d9fb293c574cac08 SHA512 f6298fee752b062672acc20e18388d7424719d69ce9586888f33be07ca92bbd7d99e46b98e9ab2a546d1954d3113b59a5105d46c4e8a13e65e1ae9acc38391ab
93 changes: 93 additions & 0 deletions app-office/gnumeric/gnumeric-1.12.47.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6..9} )

inherit gnome.org libtool python-r1 xdg

DESCRIPTION="The GNOME Spreadsheet"
HOMEPAGE="http://www.gnumeric.org/"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="+introspection libgda perl"
REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"

# Missing gnome-extra/libgnomedb required version in tree
# but its upstream is dead and will be dropped soon.

# lots of missing files, also fails tests due to 80-bit long story
# upstream bug #721556
RESTRICT="test"

# Gnumeric has two python components
# 1. The python loader for loading python-based plugins.
# This component is pure python 2 and a port "is not currently being worked on".
# 2. The python gobject-based introspection API. This component is compatible
# with python 3.
# Component 1. can only be re-enabled once someone has ported the upstream
# codebase to python 3.
# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
RDEPEND="
app-arch/bzip2
sys-libs/zlib
>=dev-libs/glib-2.40.0:2
>=gnome-extra/libgsf-1.14.33:=
>=x11-libs/goffice-0.10.46:0.10
>=dev-libs/libxml2-2.4.12:2
>=x11-libs/pango-1.24.0:=
>=x11-libs/gtk+-3.8.7:3
x11-libs/cairo:=[svg]
introspection? (
${PYTHON_DEPS}
>=dev-libs/gobject-introspection-1:=
)
perl? ( dev-lang/perl:= )
libgda? ( gnome-extra/libgda:5[gtk] )"
DEPEND="${RDEPEND}"
BDEPEND="
app-text/docbook-xml-dtd:4.5
app-text/yelp-tools
dev-util/gtk-doc-am
>=dev-util/intltool-0.35.0
virtual/pkgconfig"

src_prepare() {
default

# Manage gi overrides ourselves
sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
elibtoolize
}

src_configure() {
econf \
--disable-gtk-doc \
--disable-maintainer-mode \
--disable-schemas-compile \
--disable-static \
--without-psiconv \
--without-python \
--with-zlib \
$(use_with libgda gda) \
$(use_enable introspection) \
$(use_with perl)
}

src_install() {
default
dodoc HACKING MAINTAINERS

if use introspection; then
python_moduleinto gi.overrides
python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
fi

# no static archives
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 73dbfde

Please sign in to comment.