Skip to content

Commit

Permalink
media-libs/libmp4v2: EAPI-7 bump, fix tag corruption
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
a17r committed Oct 3, 2018
1 parent aec6872 commit 7419acc
Show file tree
Hide file tree
Showing 4 changed files with 76 additions and 5 deletions.
Original file line number Diff line number Diff line change
@@ -1,8 +1,13 @@
https://bugs.gentoo.org/show_bug.cgi?id=600892

--- mp4v2-2.0.0/src/rtphint.cpp 2012-05-20 16:11:53.000000000 -0600
+++ /tmp/rtphint.cpp 2017-05-16 10:25:26.930705191 -0600
@@ -339,7 +339,7 @@
Description: Fix pointer comparison (FTBFS on GCC 7)
Author: Philip Chung <[email protected]>
Bug-Debian: https://bugs.debian.org/853560
Last-Update: 2017-09-04

--- a/src/rtphint.cpp
+++ b/src/rtphint.cpp
@@ -339,7 +339,7 @@ void MP4RtpHintTrack::GetPayload(
pSlash = strchr(pSlash, '/');
if (pSlash != NULL) {
pSlash++;
Expand Down
20 changes: 20 additions & 0 deletions media-libs/libmp4v2/files/libmp4v2-2.0.0-mp4tags-corruption.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
From: "Matteo F. Vescovi" <[email protected]>
Date: Thu, 5 Nov 2015 15:26:00 +0100
Subject: Fix_mp4tags_corruption

---
util/mp4tags.cpp | 1 +
1 file changed, 1 insertion(+)

diff --git a/util/mp4tags.cpp b/util/mp4tags.cpp
index 1b9e866..80e89d4 100644
--- a/util/mp4tags.cpp
+++ b/util/mp4tags.cpp
@@ -539,6 +539,7 @@ extern "C" int
else {
fprintf( stderr, "Art file %s not found\n", tags[i] );
}
+ break;
}
case OPT_ALBUM_ARTIST:
MP4TagsSetAlbumArtist( mdata, tags[i] );
46 changes: 46 additions & 0 deletions media-libs/libmp4v2/libmp4v2-2.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_P=${P/lib}
inherit libtool

DESCRIPTION="Functions for accessing ISO-IEC:14496-1:2001 MPEG-4 standard"
HOMEPAGE="https://code.google.com/p/mp4v2/"
SRC_URI="https://mp4v2.googlecode.com/files/${MY_P}.tar.bz2"

LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="static-libs test utils"

BDEPEND="sys-apps/sed
utils? ( sys-apps/help2man )
test? ( dev-util/dejagnu )"

DOCS=( doc/{Authors,BuildSource,Documentation,ReleaseNotes,ToolGuide}.txt README )

S=${WORKDIR}/${MY_P}

PATCHES=(
"${FILESDIR}/${P}-gcc7.patch"
"${FILESDIR}/${P}-mp4tags-corruption.patch"
)

src_prepare() {
default
elibtoolize
}

src_configure() {
econf \
--disable-gch \
$(use_enable utils util) \
$(use_enable static-libs static)
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}
4 changes: 2 additions & 2 deletions media-libs/libmp4v2/libmp4v2-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=4
Expand All @@ -25,7 +25,7 @@ DOCS="doc/*.txt README"
S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}/gcc7.patch"
epatch "${FILESDIR}/${P}-gcc7.patch"
elibtoolize
}

Expand Down

0 comments on commit 7419acc

Please sign in to comment.