forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-crypt/rhash: Install headers, fix librhash.so symlink
Sorry, should have spotted these before the earlier commit. Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
55 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
From 30c5897a7533b746388f44f3999ad2e23c529364 Mon Sep 17 00:00:00 2001 | ||
From: James Le Cuirot <[email protected]> | ||
Date: Fri, 16 Sep 2016 22:53:51 +0100 | ||
Subject: [PATCH] Handle librhash.so symlink in shared Makefile rules, not | ||
static | ||
|
||
--- | ||
librhash/Makefile | 4 ++-- | ||
1 file changed, 2 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/librhash/Makefile b/librhash/Makefile | ||
index a38073f..fc5e5c3 100644 | ||
--- a/librhash/Makefile | ||
+++ b/librhash/Makefile | ||
@@ -46,18 +46,18 @@ dist-clean: clean | ||
install-lib-static: $(LIBRARY) install-headers | ||
$(INSTALL) -d $(DESTDIR)$(LIBDIR) | ||
$(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBDIR)/ | ||
- ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SOLINK) | ||
|
||
install-lib-shared: $(SONAME) | ||
$(INSTALL) -d $(DESTDIR)$(LIBDIR) | ||
$(INSTALL_SHARED) $(SONAME) $(DESTDIR)$(LIBDIR)/ | ||
+ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SOLINK) | ||
|
||
uninstall-lib-static: uninstall-headers | ||
rm -f $(DESTDIR)$(LIBDIR)/$(LIBRARY) | ||
- rm -f $(DESTDIR)$(LIBDIR)/$(SOLINK) | ||
|
||
uninstall-lib-shared: | ||
rm -f $(DESTDIR)$(LIBDIR)/$(SONAME) | ||
+ rm -f $(DESTDIR)$(LIBDIR)/$(SOLINK) | ||
|
||
install-headers: | ||
$(INSTALL) -d $(DESTDIR)$(INCDIR) | ||
-- | ||
2.8.2 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters