Skip to content

Commit

Permalink
app-crypt/rhash: Install headers, fix librhash.so symlink
Browse files Browse the repository at this point in the history
Sorry, should have spotted these before the earlier commit.

Package-Manager: portage-2.3.0
  • Loading branch information
chewi committed Sep 16, 2016
1 parent 6835421 commit 742b2ae
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 4 deletions.
38 changes: 38 additions & 0 deletions app-crypt/rhash/files/librhash-symlink.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
From 30c5897a7533b746388f44f3999ad2e23c529364 Mon Sep 17 00:00:00 2001
From: James Le Cuirot <[email protected]>
Date: Fri, 16 Sep 2016 22:53:51 +0100
Subject: [PATCH] Handle librhash.so symlink in shared Makefile rules, not
static

---
librhash/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/librhash/Makefile b/librhash/Makefile
index a38073f..fc5e5c3 100644
--- a/librhash/Makefile
+++ b/librhash/Makefile
@@ -46,18 +46,18 @@ dist-clean: clean
install-lib-static: $(LIBRARY) install-headers
$(INSTALL) -d $(DESTDIR)$(LIBDIR)
$(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBDIR)/
- ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SOLINK)

install-lib-shared: $(SONAME)
$(INSTALL) -d $(DESTDIR)$(LIBDIR)
$(INSTALL_SHARED) $(SONAME) $(DESTDIR)$(LIBDIR)/
+ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SOLINK)

uninstall-lib-static: uninstall-headers
rm -f $(DESTDIR)$(LIBDIR)/$(LIBRARY)
- rm -f $(DESTDIR)$(LIBDIR)/$(SOLINK)

uninstall-lib-shared:
rm -f $(DESTDIR)$(LIBDIR)/$(SONAME)
+ rm -f $(DESTDIR)$(LIBDIR)/$(SOLINK)

install-headers:
$(INSTALL) -d $(DESTDIR)$(INCDIR)
--
2.8.2

Original file line number Diff line number Diff line change
Expand Up @@ -20,6 +20,10 @@ RDEPEND="openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"

PATCHES=(
"${FILESDIR}"/librhash-symlink.patch
)

src_prepare() {
default

Expand All @@ -46,11 +50,20 @@ multilib_src_compile() {
$(use static-libs && echo lib-static)
}

myemake() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr LIBDIR='$(PREFIX)'/$(get_libdir) "${@}"
}

multilib_src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr LIBDIR='$(PREFIX)'/$(get_libdir) \
install-lib-shared $(multilib_is_native_abi && echo install-shared) \
$(use static-libs && echo install-lib-static) \
$(use nls && multilib_is_native_abi && echo install-gmo)
myemake install-lib-shared
multilib_is_native_abi && myemake install-shared
use static-libs && myemake install-lib-static
}

multilib_src_install_all() {
myemake -C librhash install-headers
use nls && myemake install-gmo
einstalldocs
}

multilib_src_test() {
Expand Down

0 comments on commit 742b2ae

Please sign in to comment.