Skip to content

Commit

Permalink
dev-python/zc-buildout: Partially enable tests
Browse files Browse the repository at this point in the history
Add missing test dependencies and python_test() implementation. Sadly,
the tests fail hard with Python 3.
  • Loading branch information
mgorny committed May 7, 2017
1 parent 4b05eca commit 743b5c5
Showing 1 changed file with 14 additions and 4 deletions.
18 changes: 14 additions & 4 deletions dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand All @@ -16,18 +16,28 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
IUSE="test"

RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
DEPEND="${RDEPEND}
test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"

S="${WORKDIR}"/${MY_P}

DOCS=( README.rst doc/tutorial.txt )
# Tests require zope packages absent from portage

# Prevent incorrect installation of data file
python_prepare_all() {
sed -e '/^ include_package_data/d' -i setup.py || die
distutils-r1_python_prepare_all
}

python_test() {
if python_is_python3; then
ewarn "Tests are broken for ${EPYTHON}, skipping"
continue
fi

distutils_install_for_testing
"${PYTHON}" src/zc/buildout/tests.py || die "Tests fail with ${EPYTHON}"
}

0 comments on commit 743b5c5

Please sign in to comment.