Skip to content

Commit

Permalink
dev-ml/lablgtk: bump to 2.18.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
aballier committed Nov 4, 2017
1 parent 8742966 commit 743e8ea
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/lablgtk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST lablgtk-2.18.5.tar.gz 808005 SHA256 2bf251db21c077fdd26c035ea03edd8fe609187f908e520e87a8ffdd9c36d233 SHA512 7b6ba1a4dfa82cc3bbc502082ff4fccc23cc06ee4f30d01a2e423f3f99e945a4befe450d230b5aa19c5b810e9f46f2838655099d49da2db7c8a2e52eac213024 WHIRLPOOL 009e1fd2a048f6833ac1d745b5fee5d618b9729fa8c73d29f7bd67b6bd5f8a9b81c361ceb69626afe6a3a09b84b98ccbf0a19e9add0329a50a8ebfbcfdaf7b85
DIST lablgtk-2.18.6.tar.gz 804837 SHA256 4ddca243066418e2a88ac49ebf2d846fac4b667b1b1753efadd078ae777368f8 SHA512 0d30da0e4a93b1693ac6d63161d40c8cd6d9337e105a65f3cc01b013ce7ca04aa5e1a013527cb0728a9b7b7af20d0f4c8b0cc7f9102e553dff3cf8bc83a14e5e WHIRLPOOL 6888d91be3cf3cd6818bb7f01323375f870e505a306699df3a34e7273e9acae05f281af90ffbb58c09a8d5f98fce7e149a34c5a3a145ffe0f535db42a3860ef0
82 changes: 82 additions & 0 deletions dev-ml/lablgtk/lablgtk-2.18.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit multilib findlib

IUSE="debug examples glade gnomecanvas sourceview +ocamlopt opengl spell svg"

DESCRIPTION="Objective CAML interface for Gtk+2"
HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
SRC_URI="https://forge.ocamlcore.org/frs/download.php/1726/${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"

RDEPEND=">=x11-libs/gtk+-2.10:2
>=dev-lang/ocaml-4.06:=[ocamlopt?]
svg? ( >=gnome-base/librsvg-2.2:2 )
glade? ( >=gnome-base/libglade-2.0.1 )
gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
opengl? ( >=dev-ml/lablgl-0.98:=
>=x11-libs/gtkglarea-1.9:2 )
spell? ( app-text/gtkspell:2 )
sourceview? ( x11-libs/gtksourceview:2.0 )
dev-ml/camlp4:=
"
DEPEND="${RDEPEND}
virtual/pkgconfig"

SLOT="2/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"

src_configure() {
econf $(use_enable debug) \
$(use_with svg rsvg) \
$(use_with glade) \
--without-gnomeui \
--without-panel \
$(use_with opengl gl) \
$(use_with spell gtkspell) \
--without-gtksourceview \
$(use_with sourceview gtksourceview2) \
$(use_with gnomecanvas)
}

src_compile() {
emake -j1 all
if use ocamlopt; then
emake -j1 opt
fi
}

install_examples() {
insinto /usr/share/doc/${P}/examples
doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm

# Install examples for optional components
use gnomecanvas && insinto /usr/share/doc/${PF}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml

docompress -x /usr/share/doc/${PF}/examples
}

src_install () {
findlib_src_preinst
export OCAMLPATH="${OCAMLFIND_DESTDIR}"
emake install DESTDIR="${D}"

rm -f "${ED}/usr/$(get_libdir)/ocaml/ld.conf"

dodoc CHANGES README CHANGES.API
use examples && install_examples
}

pkg_postinst () {
if use examples; then
elog "To run the examples you can use the lablgtk2 toplevel."
elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
fi
}

0 comments on commit 743e8ea

Please sign in to comment.