Skip to content

Commit

Permalink
app-i18n/uchardet: Version bump + maintainership
Browse files Browse the repository at this point in the history
+ Added version 0.0.7, patch from 0.0.6-r2 isn't needed there
+ EAPI 6 -> 7
+ Eclass cmake-utils -> cmake
+ I've adopted this orphaned package

Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Matthias Coppens <[email protected]>
Closes: gentoo#17066
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
MatthiasCoppens authored and juippis committed Sep 6, 2020
1 parent 74d98b9 commit 7443683
Show file tree
Hide file tree
Showing 4 changed files with 60 additions and 10 deletions.
1 change: 1 addition & 0 deletions app-i18n/uchardet/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST uchardet-0.0.6.tar.xz 169192 BLAKE2B a0bc80ecd12565c1459b8136e3dc0530250571b5adbe4a7013c561f846f64f58482b9fd9cc5aa7493f20e913f59504a6e08c26571bf33ff34b4823f55d857b8c SHA512 eceeadae060bf277e298d709856609dde32921271140dc1fb0a33c7b6e1381033fc2960d616ebbd82c92815936864d2c0743b1b5ea1b7d4a200df87df80d6de5
DIST uchardet-0.0.7.tar.xz 215492 BLAKE2B 1f8b171676bc6edf1f3493a4a370e32b7b956104ea0b12a03837d817c386d59aa512c3a107426aedb087987cf3a7b99c4b2df4a667ed685ff9959f6bc6b4506c SHA512 ddb7b63dd09c1d9acbe620d86217e583d9aa5340780ab4010ec9faa4fd331498859d5efa7829bf8847da89325accf8f7304b51d410210178fc1ffa6658064a6f
15 changes: 11 additions & 4 deletions app-i18n/uchardet/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
<bugs-to>https://bugs.freedesktop.org/enter_bug.cgi?product=uchardet</bugs-to>
</upstream>
<maintainer type="person">
<email>[email protected]</email>
<name>Matthias Coppens</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<upstream>
<bugs-to>https://bugs.freedesktop.org/enter_bug.cgi?product=uchardet</bugs-to>
</upstream>
</pkgmetadata>
36 changes: 36 additions & 0 deletions app-i18n/uchardet/uchardet-0.0.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake
if [ "${PV}" = 9999 ]
then
inherit git-r3
EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
else
SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
fi

DESCRIPTION="An encoding detector library"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"

LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="cpu_flags_x86_sse2 static-libs test"
RESTRICT="!test? ( test )"

src_prepare() {
cmake_src_prepare
use test || cmake_comment_add_subdirectory test
}

src_configure() {
local mycmakeargs=(
-DTARGET_ARCHITECTURE="${ARCH}"
-DBUILD_STATIC=$(usex static-libs)
-DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
)
cmake_src_configure
}
18 changes: 12 additions & 6 deletions app-i18n/uchardet/uchardet-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,13 +1,19 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake-utils git-r3
inherit cmake
if [ "${PV}" = 9999 ]
then
inherit git-r3
EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
else
SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
fi

DESCRIPTION="An encoding detector library"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"

LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
Expand All @@ -16,7 +22,7 @@ IUSE="cpu_flags_x86_sse2 static-libs test"
RESTRICT="!test? ( test )"

src_prepare() {
cmake-utils_src_prepare
cmake_src_prepare
use test || cmake_comment_add_subdirectory test
}

Expand All @@ -26,5 +32,5 @@ src_configure() {
-DBUILD_STATIC=$(usex static-libs)
-DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
)
cmake-utils_src_configure
cmake_src_configure
}

0 comments on commit 7443683

Please sign in to comment.