Skip to content

Commit

Permalink
dev-python/docker-py: Version bump to 3.1.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
mrueg committed Mar 20, 2018
1 parent f76f641 commit 745907f
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/docker-py/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST docker-py-2.4.2.tar.gz 180890 BLAKE2B 57518a0c8481fde0198100354225cd8a2908a
DIST docker-py-2.7.0.tar.gz 196369 BLAKE2B dd181dbf32f5afda06e748cb49f15d5fc6ff4a579c64b505308ad0d96913ddc8065d165090ec2b20e1f17a4519988a5665dd7a8c7643ca53aaa4385ceecb1341 SHA512 15cf1d8949d71e472f7636ff975cbc4c5f3e18e2d193cb603ade1397a56d0c1ec239167b71be325af99105bc36590a0f0faa1ab010f36fe8baca7807ddfa191b
DIST docker-py-3.0.1.tar.gz 199081 BLAKE2B cb0c6a56da33b43c3f2c50bd16fb7306d08c770aee42c626a36d8fc5a0a4ff6d1851ef452e6585a587ed72ef27c4c6f45c7452ab3f0f994c959795721ef8aae1 SHA512 2d4f362c1a93b004f41d8338e801280827d646cbbd98d87c6fbab3fd443a3aa7ab43e9db7ad8197d50ee735d7d264e17991f5af7d5a2483c3630ca139ae21e19
DIST docker-py-3.1.0.tar.gz 201288 BLAKE2B 0aa7f712952aac86df37f4eb8f9c60c71199454472ac14d50ee2fd5acdf1980adea6b9f065fdb920999e8d657ae37028e0aff90dd82c3e8b3b13850d748c0e97 SHA512 7f69e6095f36b7a526367bf2762704f5dc5337ba81b2733ad0b683edc271ab17f548da4398176f2e1ffaad41f8f445e1c790af14d815404ad4df7a25d0ff0b7b
DIST docker-py-3.1.1.tar.gz 201637 BLAKE2B f94ba89922eb62891113bef2b5f3d034eba0f6e91aeb657c265aa72e3b66ad5f6eba6430faae99485236689ef22e09eed3461126d84b51f369ef3004179e89c5 SHA512 139967232d687af9379e18abd1fd133fa655b6247055ae24fe9c8be02a1900d3af0bfcf0d994b7807c3623a3d1fd57e80ca18ce882855bae593321f0a85432f6
55 changes: 55 additions & 0 deletions dev-python/docker-py/docker-py-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit distutils-r1

DESCRIPTION="Python client for Docker"
HOMEPAGE="https://github.com/docker/docker-py"
SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"

RDEPEND="
>=dev-python/docker-pycreds-0.2.2[${PYTHON_USEDEP}]
!~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
>=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
$(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
>=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
)
doc? (
dev-python/recommonmark[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
sphinx-build docs html || die "docs failed to build"
HTML_DOCS=( html/. )
fi
}

python_test() {
py.test tests/unit/ || die "tests failed under ${EPYTHON}"
}

0 comments on commit 745907f

Please sign in to comment.