Skip to content

Commit

Permalink
dev-go/go-sqlite3: version bump to 1.1.0_p20160307
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
zmedico committed Mar 9, 2016
1 parent 7b4e747 commit 7469bbd
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-go/go-sqlite3/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST go-sqlite3-1.1.0_p20160131.tar.gz 1847546 SHA256 d743a044d7ee88b2783f5a15f22b47ffdaa478c0b258babc3c621ce347955bb8 SHA512 9596012111b23865191904b7b0817ddbd88fc61383a3dfcf737d3d1be95c1a1d57b779ffbb9fa83303245a992c56e427396ffccb759a440822fffa516cae0b3d WHIRLPOOL a54021a0b8deb4fd28f44e45e8c78b896ef1121e4a23eb5fe6877b259c37456a6fb4fad77300a079fc3357a14b52d0b0750286a6f15431bdfefd17a99791c7c4
DIST go-sqlite3-1.1.0_p20160307.tar.gz 1847839 SHA256 f3551d37bb2a485ef2c62c205bb104e6a19e25e3854e0106575db94891eba656 SHA512 e4613f8c18c4f5c60b09facfd6f6c36e14029538eef6deef94d57d0c0aeeed86023f36ed0fb0b7e5340ecbaad4f9b5815c5182cc19f85f52349610caaa998665 WHIRLPOOL 1eab66203e336c8081d18ba27f5aa706fc04d6c1d2b1e270457ca29d7785a3d77b36565f2b94003986a83a12618e3ffd376d8a38dee45af4c98219dce3fc69bf
35 changes: 35 additions & 0 deletions dev-go/go-sqlite3/go-sqlite3-1.1.0_p20160307.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit golang-build golang-vcs-snapshot

EGO_PN="github.com/mattn/go-sqlite3/..."
EGIT_COMMIT="10876d7dac65f02064c03d7372a2f1dfb90043fe"
ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Go sqlite3 driver using database/sql"
HOMEPAGE="https://${EGO_PN%/*}"
SRC_URI="${ARCHIVE_URI}"
LICENSE="MIT"
SLOT="0/${PVR}"
IUSE=""

src_compile() {
GOPATH="${S}" \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
}

src_install() {
golang_install_pkgs
}

golang_install_pkgs() {
insinto $(dirname "${EPREFIX}$(get_golibdir)/src/${EGO_PN%/*}")
rm -rf "${S}"/src/${EGO_PN%/*}/.git*
doins -r "${S}"/src/${EGO_PN%/*}
insinto $(dirname "${EPREFIX}$(get_golibdir)/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_PN%/*}")
doins -r "${S}"/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_PN%/*}{,.a}
}

0 comments on commit 7469bbd

Please sign in to comment.