Skip to content

Commit

Permalink
media-sound/ams: Version bump to 2.1.2
Browse files Browse the repository at this point in the history
Gentoo-bug: 561980, 588942
* EAPI=6
* Add missing depend on sci-libs/fftw
* Use Qt5 instead of Qt4
* Build with GCC 6 in C++98 mode
* [QA] Remove hardcoded CXXFLAGS

Package-Manager: portage-2.3.2
  • Loading branch information
SoapGentoo committed Nov 23, 2016
1 parent 60afb50 commit 7473973
Show file tree
Hide file tree
Showing 3 changed files with 125 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/ams/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ams-2.0.1.tar.bz2 286609 SHA256 1fb95261a302ff464b20a6b7363faed82dcbc0fa50b6580964e384ef0832ed64 SHA512 5be95ed5526de37475cb31480af9e20b6b524eb3086985680efd5dee748eb4947eb8a8265b8a805d843d1e80292fa5743e41bbd463580a0bb23c5e791d34bef8 WHIRLPOOL 57c13f4b31285ced524bb41bb31bd79c8446a8c514be219f7a228cf76a36df06db88e7bae4b2737280ef3a8146819c15426ddab6a5dbfc96628883a8583122f9
DIST ams-2.1.1.tar.bz2 342456 SHA256 a2fdd93f5f1eb96d0903d1d3f4709fcec28842e44b9e7420ea42618affc767d9 SHA512 04627c15c3e3d0b889c4d17a8393c2417f5004a2bb0035bf9b0d86265d55c214923b9b875cbf3dd2cdb3f0037a0d6f717a9c6b749b68cd786b591d79e06b7580 WHIRLPOOL 1152139cf676707369a3189795833c3a7fdbe2a90e1a557169514a12536fd5279a863058971e36592a4d322d742bed1af704776382c454029d5f718b7ef88a98
DIST ams-2.1.2.tar.bz2 348027 SHA256 808630674101cefa90567b14f4eefdb61baa0c3facbe79f2f2d692e92eccebab SHA512 3a98ccb54505818b4add1b070e2230ba00d80732fdcc54caecba55ad83f352381ed165ab58ca01fc98550bd0691242fd2f733862ee77fd217141ecec52250e4e WHIRLPOOL defd800af36a4b2af09b80ed6ad81239f383501fa13e6de4115717d7550208de6efa4ac038a36275b05692a1229be4ab81215cdc5f0cbb56456c606019acd569
44 changes: 44 additions & 0 deletions media-sound/ams/ams-2.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools flag-o-matic qmake-utils

DESCRIPTION="Alsa Modular Software Synthesizer"
HOMEPAGE="http://alsamodular.sourceforge.net"
SRC_URI="mirror://sourceforge/alsamodular/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
media-libs/ladspa-sdk
media-libs/libclalsadrv
media-libs/alsa-lib
media-sound/jack-audio-connection-kit
sci-libs/fftw:3.0=
!dev-ruby/amrita"
DEPEND="${RDEPEND}
virtual/pkgconfig"

PATCHES=( "${FILESDIR}"/${PN}-2.1.2-fix-build-system.patch )

src_prepare() {
default
eautoreconf
}

src_configure() {
# C++11/14 fails:
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811645
append-cxxflags -std=gnu++98
econf --enable-qt5 MOC="$(qt5_get_bindir)/moc"
}
80 changes: 80 additions & 0 deletions media-sound/ams/files/ams-2.1.2-fix-build-system.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
* Remove extraneous CXXFLAGS
* Missing -ldl for dlsym, dlerror, and dlopen
See also: https://bugs.gentoo.org/379251

--- a/configure.ac
+++ b/configure.ac
@@ -31,46 +31,7 @@
AC_FUNC_SELECT_ARGTYPES
AC_FUNC_STAT

-dnl set basic compiler flags
-AMS_CORE_CXXFLAGS="-Wall"
-
-dnl set compiler optimization flags
-AC_MSG_CHECKING(which processor class to optimize for)
-case "$target" in
- i486-*-*)
- AMS_OPT_CXXFLAGS="-march=i486"
- AC_MSG_RESULT(i486)
- ;;
- i586-*-*)
- AMS_OPT_CXXFLAGS="-march=pentium"
- AC_MSG_RESULT(i586)
- ;;
- i686-*-*)
- AMS_OPT_CXXFLAGS="-march=pentiumpro -msse -mfpmath=sse -ffast-math"
- AC_MSG_RESULT(i686)
- ;;
- i786-*-*)
- AMS_OPT_CXXFLAGS="-march=pentium4 -msse -mfpmath=sse -ffast-math"
- AC_MSG_RESULT(i786)
- ;;
- x86_64-*-*)
- AMS_OPT_CXXFLAGS="-m64 -msse -mfpmath=sse -ffast-math"
- AC_MSG_RESULT(x86_64)
- ;;
- *)
- AC_MSG_RESULT(i386)
- AC_MSG_WARN(This is probably not what you want, use --target)
- ;;
-esac
-
-if test "x$AMS_OPT_CXXFLAGS" = "x"; then
- AMS_CXXFLAGS=$AMS_CORE_CXXFLAGS
-else
- AC_MSG_NOTICE([Compiler optimization... $AMS_OPT_CXXFLAGS])
- AMS_CXXFLAGS="$AMS_CORE_CXXFLAGS $AMS_OPT_CXXFLAGS"
-fi
-AC_SUBST(AMS_CXXFLAGS)
-
+CXXFLAGS="${CXXFLAGS} -Wall"

# Checks for libraries.
AC_CHECK_LIB([asound], [snd_pcm_open], ,
@@ -81,8 +42,12 @@
[AC_MSG_ERROR(pthread is required)])
AC_CHECK_LIB([m], [roundf], ,
[AC_MSG_ERROR([required libm missing])])
-AC_CHECK_LIB([dl], [dlopen], ,
- [AC_MSG_ERROR(libdl is required)])
+dnl The dlopen() function is in the C library for *BSD and in
+dnl libdl on GLIBC-based systems
+AC_SEARCH_LIBS([dlopen], [dl dld], [], [
+ AC_MSG_ERROR([unable to find the dlopen() function])
+])
+
dnl for vocoder module
AC_CHECK_LIB([fftw3], [fftw_execute], ,
[AC_MSG_ERROR(libfftw3 is required)])
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -267,7 +267,7 @@
# all generated files to be removed by "make clean"
CLEANFILES = $(nodist_ams_SOURCES) $(translations_DATA)

-ams_CXXFLAGS = $(QT_CXXFLAGS) $(AMS_CXXFLAGS)
+ams_CXXFLAGS = $(QT_CXXFLAGS)
DEFS = -D_REENTRANT -DLADSPA_PATH=\"$(LADSPA_PATH)\" -DTRANSLATIONSDIR=\"$(translationsdir)\" -DDEMOFILEPATH=\"$(pkgdatadir)/demos\" -DINSTRUMENTFILEPATH=\"$(pkgdatadir)/instruments\" @DEFS@

# rule for moc-file generation

0 comments on commit 7473973

Please sign in to comment.