Skip to content

Commit

Permalink
app-arch/pxz: version bump, update live ebuild, bug #621512
Browse files Browse the repository at this point in the history
Bump package using ebuild by Brian Evans, update 9999 version similarly.

Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
grobian committed Oct 26, 2017
1 parent 837d78b commit 74f63c8
Show file tree
Hide file tree
Showing 3 changed files with 35 additions and 11 deletions.
1 change: 1 addition & 0 deletions app-arch/pxz/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pxz-5.0_pre20110811.tar.xz 11192 SHA256 0059ce89a35ed9d14634903ba1c7aae0a4af6116a6b0f04e10c4602862690ad7 SHA512 d7a837a1b777aad397752efdb0416778bd7b0da93db40528db384b5573702ff9c387c8223a65d1cdec3261cad07ca51ba8dc3bd8be18871d66f63009e144799d WHIRLPOOL f6b9dee63c2888f360f6298b04fb8d58ff20d57838faefa7e96296a37a98263d42b414380820642c9fc57d8ca4f5ff6d1eb7ddca66d09943c2676bf34b0e3a01
DIST pxz-5.0_pre20151029.tar.gz 12271 SHA256 080d655f84093ba4dafc22b44c3606ee12bad04d2bf1fd6df8877d94b1710251 SHA512 d26bfdf9b70baf91c575e21824920cb42d0a9bd171254b99147a6e5e322ed3d1f7351a570358213431bdacdcbe6e7b22646a2dd2d7a127e167c8237bc4f3038a WHIRLPOOL 113ad028f3f2e07dda6f8b124df100c51f789bec0ba44919fd14d52ac8d7c72e2a6c4ee38f5d966525f509492a10b805981e2a5d15e77d98cbdb81e8593c19b7
27 changes: 27 additions & 0 deletions app-arch/pxz/pxz-5.0_pre20151029.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit toolchain-funcs vcs-snapshot

DESCRIPTION="Parallel implementation of the XZ compression utility"
HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
SRC_URI="https://github.com/jnovy/pxz/archive/fcfea93957d96b7661d1439cf4b767ecfd341eed.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux"
IUSE=""

# needs the library from xz-utils
# needs the libgomp library from gcc at runtime
RDEPEND="app-arch/xz-utils
sys-devel/gcc:*[openmp]"
DEPEND="${RDEPEND}"

src_prepare() {
tc-check-openmp
tc-export CC
default_src_prepare
}
18 changes: 7 additions & 11 deletions app-arch/pxz/pxz-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="3"
EAPI=6

inherit toolchain-funcs flag-o-matic

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/jnovy/pxz.git"
inherit git-2
inherit git-r3
else
MY_PV=${PV/_}
case ${MY_PV} in
Expand All @@ -29,15 +29,11 @@ IUSE=""
# needs the library from xz-utils
# needs the libgomp library from gcc at runtime
DEPEND="app-arch/xz-utils
sys-devel/gcc[openmp]"
sys-devel/gcc:*[openmp]"
RDEPEND="${DEPEND}"

src_compile() {
append-lfs-flags
CFLAGS="${CFLAGS} ${CPPFLAGS}" \
emake CC="$(tc-getCC)" || die
}

src_install() {
emake install DESTDIR="${D}" || die
src_prepare() {
tc-check-openmp
tc-export CC
default_src_prepare
}

0 comments on commit 74f63c8

Please sign in to comment.