Skip to content

Commit

Permalink
dev-java/icedtea: Always disable PCH on PaX systems, bug #601016
Browse files Browse the repository at this point in the history
I will add this to 7.2 when it supports disabling PCH in 7.2.7.0.

Package-Manager: Portage-2.3.4, Repoman-2.3.2
  • Loading branch information
chewi committed Mar 8, 2017
1 parent 46851bd commit 75443af
Showing 1 changed file with 8 additions and 1 deletion.
9 changes: 8 additions & 1 deletion dev-java/icedtea/icedtea-3.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

# Build written by Andrew John Hughes ([email protected])

EAPI="6"
Expand Down Expand Up @@ -280,6 +281,13 @@ src_configure() {
config+=" --disable-ccache"
fi

# PaX breaks pch, bug #601016
if use pch && ! host-is-pax; then
config+=" --enable-precompiled-headers"
else
config+=" --disable-precompiled-headers"
fi

config+=" --with-parallel-jobs=$(makeopts_jobs)"

unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
Expand Down Expand Up @@ -310,7 +318,6 @@ src_configure() {
$(use_enable doc docs) \
$(use_enable kerberos system-kerberos) \
$(use_with pax_kernel pax "${EPREFIX}/usr/sbin/paxmark.sh") \
$(use_enable pch precompiled-headers) \
$(use_enable sctp system-sctp) \
$(use_enable smartcard system-pcsc) \
$(use_enable sunec) \
Expand Down

0 comments on commit 75443af

Please sign in to comment.