forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-base/libgnome-keyring: Add multilib support
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
1 parent
8a3f76d
commit 7574a65
Showing
1 changed file
with
64 additions
and
0 deletions.
There are no files selected for viewing
64 changes: 64 additions & 0 deletions
64
gnome-base/libgnome-keyring/libgnome-keyring-3.12.0-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="yes" | ||
GNOME2_LA_PUNT="yes" | ||
VALA_MIN_API_VERSION="0.16" | ||
VALA_USE_DEPEND="vapigen" | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit gnome2 python-any-r1 vala multilib-minimal | ||
|
||
DESCRIPTION="Compatibility library for accessing secrets" | ||
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring" | ||
|
||
LICENSE="LGPL-2+ GPL-2+" # tests are GPL-2 | ||
SLOT="0" | ||
IUSE="debug +introspection test vala" | ||
REQUIRED_USE="vala? ( introspection )" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~mips ~sh ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris" | ||
|
||
RDEPEND=" | ||
>=dev-libs/glib-2.16.0:2[${MULTILIB_USEDEP}] | ||
>=dev-libs/libgcrypt-1.2.2:0=[${MULTILIB_USEDEP}] | ||
>=sys-apps/dbus-1[${MULTILIB_USEDEP}] | ||
>=gnome-base/gnome-keyring-3.1.92 | ||
introspection? ( >=dev-libs/gobject-introspection-1.30.0 ) | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-util/gtk-doc-am | ||
>=dev-util/intltool-0.35 | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
test? ( ${PYTHON_DEPS} ) | ||
vala? ( $(vala_depend) ) | ||
" | ||
|
||
src_prepare() { | ||
use vala && vala_src_prepare | ||
gnome2_src_prepare | ||
|
||
# FIXME: Remove silly CFLAGS, report upstream | ||
sed -e 's:CFLAGS="$CFLAGS -g:CFLAGS="$CFLAGS:' \ | ||
-e 's:CFLAGS="$CFLAGS -O0:CFLAGS="$CFLAGS:' \ | ||
-i configure.ac configure || die "sed failed" | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" gnome2_src_configure \ | ||
$(multilib_native_use_enable vala) | ||
|
||
if multilib_is_native_abi; then | ||
ln -s "${S}"/docs/reference/gnome-keyring/html docs/reference/gnome-keyring/html || die | ||
fi | ||
} | ||
|
||
multilib_src_install() { | ||
gnome2_src_install | ||
} | ||
|
||
multilib_src_test() { | ||
unset DBUS_SESSION_BUS_ADDRESS | ||
dbus-launch emake check || die "tests failed" | ||
} |