Skip to content

Commit

Permalink
dev-python/aiohttp: Add v3.8.1
Browse files Browse the repository at this point in the history
Closes: gentoo#22953
Signed-off-by: Sviatoslav Sydorenko <[email protected]>
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
webknjaz authored and zmedico committed Nov 15, 2021
1 parent 326cd4d commit 75a0e88
Show file tree
Hide file tree
Showing 2 changed files with 91 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/aiohttp/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST aiohttp-3.7.4.tar.gz 1114533 BLAKE2B dcae3e66e13df8264d731a3ca65b4718feca8d0e6e1baeb6608dcb9bfb4bd4baaed6bd34297ed5ece78d01189bf9a0b9860845cae4e2b93cc2ba463cc35cfb77 SHA512 66fcc837b388020dc998cbaa2db31e48ecec75bcfaa8af9108e2ea265588dafa5684ca96a8fe3ad6759b22e09a4ae6d4efd8653fb76126eccdc826c15cbbe2e6
DIST aiohttp-3.8.0.tar.gz 7323268 BLAKE2B e3d8f6ec7c4b2de685a261171bc8e29db82b5b4677d0d4d0b103898c71184deda700f4859fff49746ace3079f09714c39d06c7d837cdc7fb26c8ebc4b29da915 SHA512 beb711812ccaab6d820c39e663e4aaba9106e270ab28ccdb8f35b74bc68509876dc30061f3df390e514e6ff8d24ede2e77e3355986ca2c5ee860eba940d72f5b
DIST aiohttp-3.8.1.tar.gz 7324180 BLAKE2B 99f85b8510782a31de2d2f6c8efa65ef5c5cde600a5c5f49d6362d5833a0443b9adcaed9beb27c5d8502aca37af154b06017f48836b73d4c61d78204b62b7f05 SHA512 3611549393e50c8d30426aee9ddd23794a71ddefe4384eb549049b93e452fafb38de7ad900737213b61fbe717bd85035a780c1622593eae250328f17d484a0a7
90 changes: 90 additions & 0 deletions dev-python/aiohttp/aiohttp-3.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} pypy3 )

inherit distutils-r1 multiprocessing

DESCRIPTION="http client/server for asyncio"
HOMEPAGE="
https://pypi.org/project/aiohttp/
https://github.com/aio-libs/aiohttp/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~riscv ~sparc ~x86"

RDEPEND="
app-arch/brotli[python,${PYTHON_USEDEP}]
>=dev-python/aiosignal-1.1.2[${PYTHON_USEDEP}]
>=dev-python/async_timeout-4.0.0_alpha3[${PYTHON_USEDEP}]
>=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
>=dev-python/charset_normalizer-2.0[${PYTHON_USEDEP}]
>=dev-python/frozenlist-1.1.1[${PYTHON_USEDEP}]
>=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
>=dev-python/yarl-1.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
app-arch/brotli[python,${PYTHON_USEDEP}]
dev-python/async_generator[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
www-servers/gunicorn[${PYTHON_USEDEP}]
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
)
"

DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )

distutils_enable_tests pytest
distutils_enable_sphinx docs \
'>=dev-python/alabaster-0.6.2' \
'dev-python/sphinxcontrib-asyncio' \
'dev-python/sphinxcontrib-blockdiag' \
'dev-python/sphinxcontrib-newsfeed' \
'dev-python/sphinxcontrib-spelling' \
'dev-python/sphinx' \
'dev-python/sphinx-aiohttp-theme'

# TODO: re-cythonize modules?

src_prepare() {
# increate a little the timeout
sed -e '/abs_tol=/s/0.001/0.01/' -i tests/test_helpers.py || die

# xfail_strict fails on py3.10
sed -i -e '/--cov/d' -e '/xfail_strict/d' setup.cfg || die
distutils-r1_src_prepare
}

python_test() {
local EPYTEST_IGNORE=(
# proxy is not packaged
tests/test_proxy_functional.py
)

local EPYTEST_DESELECT=(
# runtime warnings
'tests/test_client_functional.py::test_aiohttp_request_coroutine[pyloop]'
# Internet
tests/test_client_session.py::test_client_session_timeout_zero
)

[[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
# C extensions are not used on PyPy3
tests/test_http_parser.py::test_c_parser_loaded
)

local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock,xdist.plugin,pytest_forked
mv aiohttp aiohttp.hidden || die
epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" --forked
mv aiohttp.hidden aiohttp || die
}

0 comments on commit 75a0e88

Please sign in to comment.