Skip to content

Commit

Permalink
dev-python/pyusb: bump to 1.1.0
Browse files Browse the repository at this point in the history
Tests no longer segfault python, supports python3_9, some cosmetics.

Pushed with permission from mgorny on behalf of the Python project.

Closes: https://bugs.gentoo.org/645254
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Dec 1, 2020
1 parent 8d462cc commit 75eec14
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyusb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pyusb-1.0.2.tar.gz 68694 BLAKE2B 8910d9d6d7abd8b0dddf725ad9cc745ce5b06f69a4824a86ed9783918d0fc88d438674852288654964c4555d8278f22d3daab679149c64ea8a6fd3dd2f1cf284 SHA512 6a264b796e17612004196a7a526a7c6df99feac9062f8354540221016411a78a65d413731aea2fc1206ed5ea2b84787078898b9ca3754164f1dfe2a9878b75a5
DIST pyusb-1.1.0.tar.gz 78752 BLAKE2B ee541afedca7d5dca345c6addee2702ccb7408bb9a2d8b23fe1eb47f067a93309599894e364c0bdcef3e5348bd13cc39f240257efd4664679017f61b87853217 SHA512 0769670e6ebd8b31f2494258eca5d6e470ad3cb17663cc14b8b3a8136ea24caa23f86d81c60c501b88a9bc94b0de6a45aac43c6c5f140e65fd03a589b4d18179
28 changes: 28 additions & 0 deletions dev-python/pyusb/pyusb-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=bdepend

inherit distutils-r1

DESCRIPTION="USB support for Python"
HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"

### This version is compatible with both 0.X and 1.X versions of libusb
DEPEND="virtual/libusb:="
RDEPEND="${DEPEND}"

DOCS=( README.rst docs/tutorial.rst )

python_test() {
cd tests || die
"${PYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
}

0 comments on commit 75eec14

Please sign in to comment.