forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnustep-base/gnustep-back-cairo: 0.29.0 bump
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <[email protected]>
- Loading branch information
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnustep-back-0.28.0.tar.gz 973776 BLAKE2B c82792d9c2af45a3a81e1e40c9b0afe7b4dde7846cf4e593ec2f3e816196a321efba2d0d40d14795eed01681845bc6b5d75e8828c689961b6ba2db6de5231568 SHA512 9befc654ec431fe2a23baff2bfe848d7e4f32c58ecee877ca9606ba318ba470493469e28a5b3e37ca132f0f1262219ebd2755c3da7b26fbd1b66dddb1514d25c | ||
DIST gnustep-back-0.29.0.tar.gz 1005485 BLAKE2B c117b29ca568d3751b1aa7e0baed49d517e77fb9e7b3ab332e422cac1892b9b33d81f4cce86826e69c65ba73926ae8b7abdcf1022613680f56739f2c5a688b53 SHA512 96efd09d4cd93796fc240e160be22879b6cc600f08c615dd0d349ce9591b91b8d2afbc18332dd03861f70ebcff86de975adf352d006f2b397fcdfcf395261f7f |
47 changes: 47 additions & 0 deletions
47
gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.29.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnustep-base | ||
|
||
DESCRIPTION="Cairo back-end component for the GNUstep GUI Library" | ||
HOMEPAGE="http://www.gnustep.org" | ||
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris" | ||
IUSE="opengl xim" | ||
|
||
RDEPEND="${GNUSTEP_CORE_DEPEND} | ||
=gnustep-base/gnustep-gui-${PV%.*}* | ||
opengl? ( virtual/opengl virtual/glu ) | ||
x11-libs/libICE | ||
x11-libs/libSM | ||
x11-libs/libX11 | ||
x11-libs/libXext | ||
x11-libs/libXi | ||
x11-libs/libXmu | ||
x11-libs/libXt | ||
x11-libs/libXft | ||
x11-libs/libXrender | ||
>=media-libs/freetype-2.1.9 | ||
>=x11-libs/cairo-1.2.0[X] | ||
!gnustep-base/gnustep-back-art | ||
!gnustep-base/gnustep-back-xlib" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/gnustep-back-${PV} | ||
|
||
src_configure() { | ||
egnustep_env | ||
|
||
myconf="$(use_enable opengl glx)" | ||
myconf="$myconf $(use_enable xim)" | ||
myconf="$myconf --enable-server=x11" | ||
myconf="$myconf --enable-graphics=cairo" | ||
|
||
econf $myconf | ||
} |