Skip to content

Commit

Permalink
dev-db/timescaledb: add 2.9.2
Browse files Browse the repository at this point in the history
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Feb 5, 2023
1 parent a884edc commit 7603881
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/timescaledb/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST timescaledb-2.9.0.tar.gz 7340009 BLAKE2B b7eb3bb5f866b09ff8c78c4430fa570dd491336428cb74f4d9f961a7f0432dde5dcef58533acdc9541f8c49e93a6d62af4e37762b73de334437276c8e9a39f80 SHA512 7dd7a3d8cc3f3d6480b411c6254e055a723c48c5312a349d4f6e35932798cf8413f77c8b51fb193bdcdc8eee2b3eca970df1fd0a4fa160e3ad433f86e55dc7c7
DIST timescaledb-2.9.1.tar.gz 7338112 BLAKE2B 83d0c6fab142de4b7e25ba75c3851e4cec794b3e2b79cbd2e44e15f19311913cf3112728797b2ef5fc282122160c3e5e19d01338da260892a9c1d71a53008414 SHA512 2f8c374517ede11cd65c7e281b2318604734508d7e4d12d447d13c7df6e77fa15a1c5580b64a28d57b94cebb95cf220c1a9d69fb1c3e0f044aab142232ebf61a
DIST timescaledb-2.9.2.tar.gz 7265748 BLAKE2B 6d821f3e93e5a4c8cb871e436b00f81befbc82b171c95c50f93d278c2dd87c44255c4fc7b6e09e7463eeb8b3ba6719ad95d07d76d2234a52f7f0ca015a1ed727 SHA512 2f8153e37e3fd1488f89398dfb6b4501267c0d4bae4b796738d0b25e26f9720c7d6388b41fd952b4760f9e85adfbf6d3b37f4f5b7cc9ec3e68825dbd9868e870
67 changes: 67 additions & 0 deletions dev-db/timescaledb/timescaledb-2.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

POSTGRES_COMPAT=( 12 13 14 15 )
POSTGRES_USEDEP="ssl"

inherit postgres-multi cmake

DESCRIPTION="Open-source time-series SQL database"
HOMEPAGE="https://www.timescale.com/"
SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

IUSE="proprietary-extensions"
LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"

KEYWORDS="~amd64"

SLOT=0

RESTRICT="test"

DEPEND="${POSTGRES_DEP}"
RDEPEND="${DEPEND}"

CMAKE_IN_SOURCE_BUILD=yes
CMAKE_BUILD_TYPE="RelWithDebInfo"
BUILD_DIR=${WORKDIR}/${P}

src_prepare() {
postgres-multi_src_prepare
postgres-multi_foreach cmake_src_prepare
}

timescale_configure() {
local CMAKE_USE_DIR=$BUILD_DIR
local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )

# licensing is tied to features, this useflag disables the non-apache2 licensed bits
if ! use proprietary-extensions ; then
mycmakeargs+=("-DAPACHE_ONLY=ON")
fi
cmake_src_configure
}

src_configure() {
postgres-multi_foreach timescale_configure
}

timescale_src_compile() {
local CMAKE_USE_DIR=$BUILD_DIR
cmake_src_compile
}

src_compile() {
postgres-multi_foreach timescale_src_compile
}

timescale_src_install() {
local CMAKE_USE_DIR=$BUILD_DIR
cmake_src_install
}

src_install() {
postgres-multi_foreach timescale_src_install
}

0 comments on commit 7603881

Please sign in to comment.