Skip to content

Commit

Permalink
app-arch/gtk-splitter: fix compilation with format-security
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/520974
Package-Manager: Portage-3.0.16, Repoman-3.0.2
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Mar 4, 2021
1 parent 2ba83dd commit 76116a0
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 2 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
--- a/src/dostextfile.c
+++ b/src/dostextfile.c
@@ -30,14 +30,14 @@
/* Write a string to the file pointed to by b without the eoln. */
void write_dostextfile(FILE *b, char *data)
{
- fprintf( b, data );
+ fprintf( b, "%s", data );
fflush( b );
}

/* Write a string to the file pointed to by b with the eoln. */
void writeln_dostextfile(FILE *b, char *data)
{
- fprintf( b, data );
+ fprintf( b, "%s", data );
fputc( 0x0d, b );
fputc( 0x0a, b );
fflush( b );
--- a/src/interface.c
+++ b/src/interface.c
@@ -216,6 +216,7 @@
GTK_DIALOG_MODAL,
GTK_MESSAGE_ERROR,
GTK_BUTTONS_CLOSE,
+ "%s",
error );

/* Display the error dialog. */
@@ -233,12 +234,14 @@
GTK_DIALOG_MODAL,
GTK_MESSAGE_INFO,
GTK_BUTTONS_CLOSE,
+ "%s",
"File verification successful" );
else
dialog = gtk_message_dialog_new( NULL,
GTK_DIALOG_MODAL,
GTK_MESSAGE_WARNING,
GTK_BUTTONS_CLOSE,
+ "%s",
"File verification unsuccessful" );

/* Display the error dialog. */
7 changes: 5 additions & 2 deletions app-arch/gtk-splitter/gtk-splitter-2.2.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand All @@ -19,7 +19,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

PATCHES=( "${FILESDIR}"/${P}-r1-desktop-QA-fixes.patch )
PATCHES=(
"${FILESDIR}"/${P}-r1-desktop-QA-fixes.patch
"${FILESDIR}"/${P}-format-security.patch
)

src_configure() {
default
Expand Down

0 comments on commit 76116a0

Please sign in to comment.