Skip to content

Commit

Permalink
dev-python/zeroconf: Bump to 0.47.4
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Mar 21, 2023
1 parent a6c7735 commit 762d25d
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/zeroconf/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST python-zeroconf-0.47.3.gh.tar.gz 151413 BLAKE2B eff81832a029cf173c55290355207bfd17b1701f85c60be544252d00579ad835eb2b7c0a29c967ba62b1293d9efae953bc3b564c5ca134c2a898621584cdf544 SHA512 e1435490ba6890d9f0fe8efd7be64f0f9fd20a6ae723b176861865a8a795593db7cd797062f9977a5b1df4107781011d25bdf69dd4cc54dd94ef6e891c425df4
DIST python-zeroconf-0.47.4.gh.tar.gz 151640 BLAKE2B 4591135e81fc0c1c22444fb8823f5ad246f234a79a9aa2697a947a7838f5880007e2acbfe8c60a3f69c0a1cf803e35b35b17b7cf013dc7408e759273bbca94b2 SHA512 2b8438e0832cfc6ac40d54eaed75749389fd9287b82b074f129bba76e7f31e3cfd58e5de28c54b3cf3e14d3c8540ff09b5f10d85f705ede2ef18718b1a87ebf1
61 changes: 61 additions & 0 deletions dev-python/zeroconf/zeroconf-0.47.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{9..11} )

inherit distutils-r1

MY_P=python-zeroconf-${PV}
DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
HOMEPAGE="
https://github.com/python-zeroconf/python-zeroconf/
https://pypi.org/project/zeroconf/
"
SRC_URI="
https://github.com/python-zeroconf/python-zeroconf/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
>=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
' 3.{9..10})
"
# the build system uses custom build script that uses distutils to build
# C extensions, sigh
BDEPEND="
>=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
>=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

python_test() {
local EPYTEST_DESELECT=(
# network
tests/test_core.py::Framework::test_close_multiple_times
tests/test_core.py::Framework::test_launch_and_close
tests/test_core.py::Framework::test_launch_and_close_context_manager
tests/test_core.py::Framework::test_launch_and_close_v4_v6
tests/test_core.py::Framework::test_launch_and_close_v6_only
tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6

# fragile to timeouts (?)
tests/services/test_browser.py::test_service_browser_expire_callbacks
tests/utils/test_asyncio.py::test_run_coro_with_timeout
)

epytest -o addopts=
}

0 comments on commit 762d25d

Please sign in to comment.