Skip to content

Commit

Permalink
dev-python/pyhcl: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
mrueg committed Jun 13, 2017
1 parent edc9fec commit 767f848
Show file tree
Hide file tree
Showing 3 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyhcl/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST pyhcl-0.2.3.tar.gz 21796 SHA256 99f49100162a93a746b36903afef964132949f640f5e74c0e0de9106eaf1ac53 SHA512 09cc9dd53048170ad49794d0944acaacba2c08bc5a05bb8d699bb47dc0a03eb32881ddf4dc0771e8b6ee008f7a47b5e95beed4bd77b173c88c6cc322eff4678f WHIRLPOOL 421b4167ff7a2e2e41d9441eb7a17b16b9830ae430c19c03b8c6a2a4b340e0a2039d1551c1b5fda5aefb6cbae522accd03bf2b2e3363d17db0fac78ee4ce113d
15 changes: 15 additions & 0 deletions dev-python/pyhcl/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Manuel Rüger</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Python</name>
</maintainer>
<upstream>
<remote-id type="github">virtuald/pyhcl</remote-id>
</upstream>
</pkgmetadata>
30 changes: 30 additions & 0 deletions dev-python/pyhcl/pyhcl-0.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit distutils-r1

DESCRIPTION="HCL configuration parser for python"
HOMEPAGE="https://github.com/virtuald/pyhcl"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

RDEPEND=">=dev-python/ply-3.4[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

python_prepare_all() {
sed -i -e "s/==.*$//" requirements.txt || die
distutils-r1_python_prepare_all
}

python_test() {
py.test -v || die
}

0 comments on commit 767f848

Please sign in to comment.