Skip to content

Commit

Permalink
dev-ml/mtime: bump 1.2.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jul 16, 2021
1 parent 5ac86fc commit 76cf489
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/mtime/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mtime-1.1.0.tbz 15467 BLAKE2B 975fdb01c6a4806035a5fbc256d192d6c2f45bdfb750045293b10a732c5613108d9bce897d3c1be660af60d6e9bafbf299dedbc0d872d1c09f65f47b11c9a6b6 SHA512 8ed5dae589dd27fc6e748218a9d9fb9d7d954d231fc2100d61c1b336e0ed38a215bc608cdea9965547729177c78c868c1de6a5ceac6735686a3de1c4a791746c
DIST mtime-1.2.0.tbz 16272 BLAKE2B 317201f8d5e7a55636e58748ffd269db5e88aed012e8dd7ed269d1f128f8d21ed0e707679b030b9c822bac98c9b76033e8d2402171c4ee758d8c936fbeee7ee9 SHA512 0f0ed220cd0f899643930814010f8592e1f47b6dc6c4dce8eebfb17a81b0abed093a3dbf9c02490af99bf81ea640372f73b4ab88fd8ef0e0c7c66920692a8778
33 changes: 33 additions & 0 deletions dev-ml/mtime/mtime-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit opam

DESCRIPTION="OCaml module to access monotonic wall-clock time"
HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"

LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="dev-lang/ocaml:=[ocamlopt]"
DEPEND="${RDEPEND}
dev-ml/topkg
dev-ml/ocamlbuild
dev-ml/findlib"

src_compile() {
ocaml pkg/pkg.ml build \
--with-js_of_ocaml false \
--tests $(usex test true false) \
|| die
}

src_test() {
ocaml pkg/pkg.ml test || die
}

0 comments on commit 76cf489

Please sign in to comment.