forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libmygpo-qt: Bump to version 1.0.8
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Jan 13, 2016
1 parent
d978767
commit 773d097
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST libmygpo-qt-1.0.7.tar.gz 62703 SHA256 43b9c00ae2c206ac64cf725918024b3d0927bbde880196a016f2ee329bac50fd SHA512 b1aad4daa32a41173d060f026245074ff2d11b9747447cb97cea9e3b93ea42e9ce89f67d4ed6396ed2b087db1f149e12543fb0a5d897e74a359c3115a418b45b WHIRLPOOL 5d7bbcf724677bc326060d4c8f79cadddd32caa240b830acdf2bcf0f213f6712dc2082fd1d6ad711edd23addd72e7553fdce1f2f1726cc0f8694ed9d4c4e04ae | ||
DIST libmygpo-qt-1.0.8.tar.gz 65064 SHA256 a0133b9d1850140a85d045d5a5db568735d19d62cd2f415e56e8b96689e2ce2e SHA512 1681b37387f7c18b74acbe5babd0ed435b289e87bca16e8c9ac7de53ff16012a82ed091cb77fd8c7972d470a71f38d1c9ab7c5f1e1bfe69db74f6fdc8d8a9bc8 WHIRLPOOL 51f7a503dfd4a893857d35b53010cecb9d278e9f4ab6424e07fbe3bc4d6c124eb7d36fcf1b437ea5349312ae21862a91189dc8da9cae5f763717d94ed2f1725a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit cmake-utils | ||
|
||
DESCRIPTION="Qt/C++ library wrapping the gpodder.net webservice" | ||
HOMEPAGE="http://wiki.gpodder.org/wiki/Libmygpo-qt" | ||
|
||
if [[ ${PV} == *9999* ]]; then | ||
EGIT_REPO_URI="https://github.com/gpodder/libmygpo-qt.git" | ||
KEYWORDS="" | ||
SRC_URI="" | ||
inherit git-2 | ||
else | ||
KEYWORDS="~amd64 ~x86" | ||
SRC_URI="https://github.com/gpodder/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
fi | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
IUSE="test" | ||
|
||
RDEPEND="dev-qt/qtcore:4 | ||
>=dev-libs/qjson-0.5" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
test? ( dev-qt/qttest:4 )" | ||
|
||
DOCS=( AUTHORS README ) | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
if ! use test ; then | ||
sed -i -e '/find_package/s/QtTest//' CMakeLists.txt || die | ||
fi | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use test MYGPO_BUILD_TESTS) | ||
) | ||
cmake-utils_src_configure | ||
} |