forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/keepassxc: Bump to version 2.4.3
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Jun 12, 2019
1 parent
951915f
commit 7752e8d
Showing
2 changed files
with
100 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST keepassxc-2.3.4-src.tar.xz 4137176 BLAKE2B bbf8dbef5fb365f3c0d9332454b2b3bce7d4e411f43939ae683428ca669a459f1662bb8b1a1da228bc9447ee15349a5cd558e4fdfcc5194f22401f56003fd0f0 SHA512 edca22ef9d7c553d21d8ea6115a5635265176acc56fdf055f1961a3e65046de49ed5b67eb68ecf4f925226fb5bca140d5d473a5082301168f6a8bb7979f562a8 | ||
DIST keepassxc-2.4.1-src.tar.xz 3277856 BLAKE2B 64ed15987f26fd884db8fec9dc8e5d9ecd1ab9c298c2c35ee41f5aacd51bf3cd512c8ca0370ccc294d4f1ac6214678d2a3a4d8c47441c01ae8e858252018ec97 SHA512 4369043700d3de4fece0a1dd0f8aab3f621df379bc9d0214b4c70ab72d081f978104aa09fd39c4b4bf8b8df8f78266835dc206c31e7174bdf872a977c0d79502 | ||
DIST keepassxc-2.4.2-src.tar.xz 3290468 BLAKE2B bcb4974729c771073b6ccf4f5af5ac94a237c349dacc10be5db698630e4fc8fc226a6911957c1ea4723dfce9aa348c11588aa1e5927487cdd36d9c8bae0d7758 SHA512 4ad7e559a36831ad715672d3cddcd3becd4f39847b7ad4451d920c76671e607f8ec9d65ed6f5450dd95e037d129cafe8faff8c1ecd9d20a22fed2c72b2dde9f2 | ||
DIST keepassxc-2.4.3-src.tar.xz 3301944 BLAKE2B ba95d5d48049367e7d3c39b5fdc9fc9816dfe2b257530068f229d1b5bd4eb9c137607f63bcce0aac4bc67ed41ee00c0385be800720acfdc3920c44444cade180 SHA512 893f1d18ab8051143d29c568ba87adcc42a13d28d0c3a7af04396cd91d6724f8a98d76d2e20ca15138c4642ec060d48b9e957857251f3a0df6066af08cd0765d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,99 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake-utils xdg | ||
|
||
DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition" | ||
HOMEPAGE="https://keepassxc.org" | ||
|
||
if [[ "${PV}" != 9999 ]] ; then | ||
if [[ "${PV}" == *_beta* ]] ; then | ||
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/${P/_/-}" | ||
else | ||
#SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
else | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}" | ||
fi | ||
|
||
LICENSE="LGPL-2.1 GPL-2 GPL-3" | ||
SLOT="0" | ||
IUSE="autotype browser debug keeshare +network test yubikey" | ||
|
||
RDEPEND=" | ||
app-crypt/argon2:= | ||
dev-libs/libgcrypt:= | ||
>=dev-libs/libsodium-1.0.12:= | ||
dev-qt/qtconcurrent:5 | ||
dev-qt/qtcore:5 | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtsvg:5 | ||
dev-qt/qtwidgets:5 | ||
media-gfx/qrencode:= | ||
sys-libs/zlib:= | ||
autotype? ( | ||
dev-qt/qtx11extras:5 | ||
x11-libs/libX11 | ||
x11-libs/libXi | ||
x11-libs/libXtst | ||
) | ||
browser? ( >=dev-libs/libsodium-1.0.12 ) | ||
keeshare? ( dev-libs/quazip ) | ||
yubikey? ( sys-auth/ykpers ) | ||
" | ||
|
||
DEPEND=" | ||
${RDEPEND} | ||
dev-qt/linguist-tools:5 | ||
dev-qt/qttest:5 | ||
" | ||
|
||
# Not a runtime dependency but still needed (see bug #667092) | ||
PDEPEND=" | ||
x11-misc/xsel | ||
" | ||
|
||
src_prepare() { | ||
use test || \ | ||
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_GUI_TESTS=OFF | ||
-DWITH_TESTS="$(usex test)" | ||
-DWITH_XC_AUTOTYPE="$(usex autotype)" | ||
-DWITH_XC_BROWSER="$(usex browser)" | ||
-DWITH_XC_KEESHARE_SECURE="$(usex keeshare)" | ||
-DWITH_XC_NETWORKING="$(usex network)" | ||
-DWITH_XC_SSHAGENT=ON | ||
-DWITH_XC_UPDATECHECK=OFF | ||
-DWITH_XC_YUBIKEY="$(usex yubikey)" | ||
) | ||
if [[ "${PV}" == *_beta* ]] ; then | ||
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" ) | ||
fi | ||
cmake-utils_src_configure | ||
} | ||
|
||
pkg_preinst() { | ||
xdg_pkg_preinst | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
} |