Skip to content

Commit

Permalink
net-libs/courier-authlib: Re-add 0.67.0 for arm64.
Browse files Browse the repository at this point in the history
Removal of old versions broke dependencies and CI for
courier-imap.

Signed-off-by: Hanno Boeck <[email protected]>
Package-Manager: Portage-2.3.52, Repoman-2.3.12
RepoMan-Options: --force
  • Loading branch information
hannob committed Dec 19, 2018
1 parent a38bd2f commit 77e480e
Show file tree
Hide file tree
Showing 2 changed files with 150 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/courier-authlib/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST courier-authlib-0.65.0.tar.bz2 2303751 BLAKE2B 595a91a87d9f0f87ded7db73f88a9a74f8e5140452cab2bada43de9836b4f3e8b123dbb10295493e71e52e1920950f28d67a74ec026ff33c27ffa14024d079a1 SHA512 edc4a51bc0d748e7d6cdbf9e9c67c43eeedd9e3846d91a8eea24613f6fb5125d2e713ef7fd63cbbe1905205f2a406b4ff3f31d7c3fb7028939123dbc728d8e38
DIST courier-authlib-0.66.4.tar.bz2 2192331 BLAKE2B 8fd68153b2defb63bbafb44b34c0f7ab5f7156800dc3eeb3c31fc0952c9a4637d4937babceae624c1a22512076bb11a1a356e0e0332c13d61026470a03b7e1c9 SHA512 0987bc9d33a013ae842e0ea3e4e83ef9d6196c2f923a6970e049a36b8ccddbf0c4465c43c7e27d6718480e981f573795f6417478de1ff685264f3439e8dffdc9
DIST courier-authlib-0.67.0.tar.bz2 2194546 BLAKE2B 2ccb6ed15c2f02d206606f8bba04c9f2da415da3d739e456914e44010c955c9aaeae1f1c0746c8812f5165eb8db1997284e1c378132a6144da2b8f77d77a6eff SHA512 6e3da28d555761177727c44b1422bf5baf6ffbf28f53cea89a4a8e13daa5433803deba1614295d9679c41b5be4750f464e7869a2d3ecbfd91ae84e7281c4f3ef
DIST courier-authlib-0.68.0.tar.bz2 2194982 BLAKE2B e463390b49bb3ca147467d3054a83d5a8ce96b604bde0b624c4d7ce81235c6f747e5d847dde794c81c4ad36aeef49bdd27cf904142b4542df833484c5eb7a57e SHA512 5c4adaf0fd69f4b9e780962aa3f9eeac6b15cea3f302288ff4549ce2b0be9ea0808b4501670ef3c4e0419c3d27505c256c082f795dea4683dd5265fd7dcab93b
149 changes: 149 additions & 0 deletions net-libs/courier-authlib/courier-authlib-0.67.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,149 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic

KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"

DESCRIPTION="Courier authentication library"
SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
HOMEPAGE="http://www.courier-mta.org/"
LICENSE="GPL-3"
SLOT="0"
IUSE="berkdb crypt debug gdbm ldap libressl mysql pam postgres sqlite static-libs"

RESTRICT="!berkdb? ( test )"

DEPEND="net-mail/mailbase
>=net-libs/courier-unicode-1.3
gdbm? ( sys-libs/gdbm )
!gdbm? ( sys-libs/db:= )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
ldap? ( >=net-nds/openldap-1.2.11 )
mysql? ( virtual/mysql )
pam? ( virtual/pam )
postgres? ( dev-db/postgresql:= )
sqlite? ( dev-db/sqlite:3 )"

RDEPEND="${DEPEND}"

pkg_setup() {
if ! has_version 'dev-tcltk/expect' ; then
ewarn 'The dev-tcltk/expect package is not installed.'
ewarn 'Without it, you will not be able to change system login passwords.'
ewarn 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
ewarn 'and others) will work just fine.'
fi
}

src_configure() {
filter-flags -fomit-frame-pointer
local myconf
if use berkdb ; then
if use gdbm ; then
ewarn "Both gdbm and berkdb selected. Using gdbm."
else
myconf="--with-db=db"
fi
fi
use gdbm && myconf="--with-db=gdbm"
use debug && myconf+=" debug=true"
use sqlite && myconf+=" --with-sqlite-libs"

econf \
--sysconfdir=/etc/courier \
--datadir=/usr/share/courier \
--libexecdir=/usr/$(get_libdir)/courier \
--localstatedir=/var/lib/courier \
--sharedstatedir=/var/lib/courier/com \
--with-authdaemonvar=/var/lib/courier/authdaemon \
--with-authshadow \
--without-redhat \
--with-mailuser=mail \
--with-mailgroup=mail \
--cache-file="${S}/configuring.cache" \
$(use_with pam authpam) \
$(use_with ldap authldap) \
$(use_with mysql authmysql) \
$(use_with postgres authpgsql) \
$(use_with sqlite authsqlite) \
${myconf}
}

orderfirst() {
file="${D}/etc/courier/authlib/${1}" ; option="${2}" ; param="${3}"
if [[ -e "${file}" ]] ; then
orig="$(grep ^${option}= ${file} | cut -d\" -f 2)"
new="${option}=\"${param} `echo ${orig} | sed -e\"s/${param}//g\" -e\"s/ / /g\"`\""
sed -i -e "s/^${option}=.*$/${new}/" "${file}" || die
fi
}

finduserdb() {
for dir in \
/etc/courier/authlib /etc/courier /etc/courier-imap \
/usr/lib/courier/etc /usr/lib/courier-imap/etc \
/usr/local/etc /usr/local/etc/courier /usr/local/courier/etc \
/usr/local/lib/courier/etc /usr/local/lib/courier-imap/etc \
/usr/local/share/sqwebmail /usr/local/etc/courier-imap ; do
if [[ -e "${dir}/userdb" ]] ; then
einfo "Found userdb at: ${dir}/userdb"
cp -fR "${dir}/userdb" "${D}/etc/courier/authlib/" || die
chmod go-rwx "${D}/etc/courier/authlib/userdb" || die
continue
fi
done
}

src_install() {
diropts -o mail -g mail
dodir /etc/courier
keepdir /var/lib/courier/authdaemon
keepdir /etc/courier/authlib
emake DESTDIR="${D}" install
[[ ! -e "${D}/etc/courier/authlib/userdb" ]] && finduserdb
emake DESTDIR="${D}" install-configure
rm -f "${D}"/etc/courier/authlib/*.bak
chown mail:mail "${D}"/etc/courier/authlib/* || die
for y in "${D}"/etc/courier/authlib/*.dist ; do
[[ ! -e "${y%%.dist}" ]] && cp -f "${y}" "${y%%.dist}"
done
use pam && orderfirst authdaemonrc authmodulelist authpam
use ldap && orderfirst authdaemonrc authmodulelist authldap
use sqlite && orderfirst authdaemonrc authmodulelist authsqlite
use postgres && orderfirst authdaemonrc authmodulelist authpgsql
use mysql && orderfirst authdaemonrc authmodulelist authmysql

DOCS=( AUTHORS ChangeLog* INSTALL NEWS README )
HTML_DOCS=( README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html )
if use mysql ; then
DOCS+=( README.authmysql.myownquery )
HTML_DOCS+=( README.authmysql.html )
fi
if use postgres ; then
HTML_DOCS+=( README.authpostgres.html README.authmysql.html )
fi
if use ldap ; then
DOCS+=( README.ldap )
dodir /etc/openldap/schema
cp -f authldap.schema "${D}/etc/openldap/schema/" || die
fi
if use sqlite ; then
HTML_DOCS+=( README.authsqlite.html README.authmysql.html )
fi
einstalldocs

newinitd "${FILESDIR}/${PN}-r1" "${PN}"

use static-libs || find "${D}" -name "*.a" -delete
}

pkg_postinst() {
if [[ -e /etc/courier/authlib/userdb ]] ; then
einfo "Running makeuserdb ..."
chmod go-rwx /etc/courier/authlib/userdb || die
makeuserdb
fi
}

0 comments on commit 77e480e

Please sign in to comment.