Skip to content

Commit

Permalink
sys-fs/dosfstools: Don't link to udev via LDFLAGS.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed May 10, 2016
1 parent 68d2e70 commit 77fb06e
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 2 deletions.
13 changes: 11 additions & 2 deletions sys-fs/dosfstools/dosfstools-4.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@

EAPI="5"

inherit toolchain-funcs flag-o-matic
inherit autotools toolchain-funcs flag-o-matic

DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
HOMEPAGE="https://github.com/dosfstools/dosfstools"
Expand All @@ -20,7 +20,16 @@ DEPEND="${CDEPEND}
udev? ( virtual/pkgconfig )"
RDEPEND="${CDEPEND}"

#RESTRICT="test" # there is no test target #239071
RESTRICT="test" # there is no test target #239071

PATCHES=(
"${FILESDIR}/${P}-udevlibs.patch"
)

src_prepare() {
epatch "${PATCHES[@]}"
eautoreconf
}

src_configure() {
econf \
Expand Down
36 changes: 36 additions & 0 deletions sys-fs/dosfstools/files/dosfstools-4.0-udevlibs.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
From 7538785afd751de509cd00740adf57fc6d730e33 Mon Sep 17 00:00:00 2001
From: Lars Wendler <[email protected]>
Date: Tue, 10 May 2016 09:47:57 +0200
Subject: [PATCH] Don't link to udev via LDFLAGS. There's LDADD for such a
task.

See also:
https://www.gnu.org/software/automake/manual/html_node/Linking.html

Signed-off-by: Lars Wendler <[email protected]>
---
src/Makefile.am | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/Makefile.am b/src/Makefile.am
index 3d22ba7..a15e6e7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,12 +34,12 @@ mkfs_common_sources = device_info.c device_info.h \
mkfs_fat_SOURCES = mkfs.fat.c msdos_fs.h $(mkfs_common_sources)
mkfs_fat_CPPFLAGS = -I$(srcdir)/blkdev
mkfs_fat_CFLAGS = $(AM_CFLAGS) $(UDEV_CFLAGS)
-mkfs_fat_LDFLAGS = $(UDEV_LIBS)
+mkfs_fat_LDADD = $(UDEV_LIBS)

testdevinfo_SOURCES = testdevinfo.c $(mkfs_common_sources)
testdevinfo_CPPFLAGS = -I$(srcdir)/blkdev
testdevinfo_CFLAGS = $(AM_CFLAGS) $(UDEV_CFLAGS)
-testdevinfo_LDFLAGS = $(UDEV_LIBS)
+testdevinfo_LDADD = $(UDEV_LIBS)


if COMPAT_SYMLINKS
--
2.8.2

0 comments on commit 77fb06e

Please sign in to comment.