forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-print/epson-inkjet-printer-escpr: Bump to 1.6.1
Bug: https://bugs.gentoo.org/564516 Package-Manager: portage-2.2.23_p18
- Loading branch information
Showing
3 changed files
with
79 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST epson-inkjet-printer-escpr-1.4.4-1lsb3.2.tar.gz 2432872 SHA256 bec7c51d11d96b6448bd96b5e9ac622786e3fc5024e13cae2fc248f8858db2f6 SHA512 7a3f1f880dba9048773d051cfe54ea2ee929d82a85efb496d4df4b84b33ed2f48bb6020892615d5d22da6b5671501b82df55cea6e11b35fea392392f115a6330 WHIRLPOOL 856bcffc4fe45c6bb15c7ecbe1c41e315ee68bf2c3c93697ac4f314324e2b3a0a8796ba741c04e962f1ca9148dbf38d529649ffd5d7ddaaa757666ea066e32a0 | ||
DIST epson-inkjet-printer-escpr-1.5.2-1lsb3.2.tar.gz 2852564 SHA256 9229aa8a033e97e29b0671082d08e1c56ebbee4e5adb2f350f81181835f06be8 SHA512 680ffa68ea84830463bea1e6ffc4e1380ed60dc45689844afa15989177a8c3a2a67becd8a7b899b6ee6c8078de9b217563af06c70b1d42aefa7469327c0601af WHIRLPOOL 1abaf4954781c2734e13a79f7dfde26d27ddec45fd360fa1983d544fe49123ff92305b9b30fdd8482d0c2f5cb954d1e7472d9cd18804cd093c41f81669bf5970 | ||
DIST epson-inkjet-printer-escpr-1.6.1-1lsb3.2.tar.gz 3044091 SHA256 bb7dea7439c571662db9cf7a8834cb87ed69fa249a7945218403187c6097c76f SHA512 e4e6749ffcb8dd3b35bb6ba931165695b1b983fd9b47d5981358d191870c9658fec92aff63352b854f7d1362129e2359ef96166713ed11863e3536dbb5832bb3 WHIRLPOOL e958b2921541177255176f9efd512ac0b981f2faf8828dc03409c364d14dc53ec113dcd37f116b12ecf0a3d8e59e1df9b589ec88f6fabf10ba61707386990126 |
38 changes: 38 additions & 0 deletions
38
net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.6.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils multilib | ||
|
||
DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R)" | ||
HOMEPAGE="http://www.epson.com/" | ||
SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/04/23/02/a5ee7e1622b0ba692bea6763d6d7f4810a8d0808/epson-inkjet-printer-escpr-1.6.1-1lsb3.2.tar.gz" | ||
# http://download.ebz.epson.net/dsc/search/01/search/ | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
DEPEND="net-print/cups" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
epatch "${FILESDIR}/1.6.1-warnings.patch" | ||
} | ||
|
||
src_configure() { | ||
econf --disable-shared | ||
|
||
# Makefile calls ls to generate a file list which is included in Makefile.am | ||
# Set the collation to C to avoid automake being called automatically | ||
unset LC_ALL | ||
export LC_COLLATE=C | ||
} | ||
|
||
src_install() { | ||
default | ||
rm -r "${ED%/}/usr/$(get_libdir)" || die | ||
} |
40 changes: 40 additions & 0 deletions
40
net-print/epson-inkjet-printer-escpr/files/1.6.1-warnings.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
--- a/lib/epson-escpr-api.h | ||
+++ b/lib/epson-escpr-api.h | ||
@@ -111,6 +111,9 @@ | ||
/*** -------------------------------------------------------------------------------*/ | ||
extern EPS_ERR_CODE epsMakeMainteCmd (EPS_INT32, EPS_UINT8*, EPS_UINT32* ); | ||
|
||
+extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB* ); | ||
+extern EPS_ERR_CODE SendStartJob (EPS_BOOL ); | ||
+extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32* ); | ||
#ifdef __cplusplus | ||
} | ||
#endif | ||
--- a/src/filter.c | ||
+++ b/src/filter.c | ||
@@ -37,6 +37,7 @@ | ||
#include "epson-escpr-api.h" | ||
#include "epson-escpr-services.h" | ||
#include "epson-escpr-mem.h" | ||
+#include "epson-escpage.h" | ||
|
||
#include "err.h" | ||
#include "mem.h" | ||
@@ -45,6 +46,7 @@ | ||
#include "libprtX.h" | ||
#include "optBase.h" | ||
#include "linux_cmn.h" | ||
+#include "xfifo.h" | ||
|
||
#define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4) | ||
|
||
--- a/src/mem.c | ||
+++ b/src/mem.c | ||
@@ -23,6 +23,7 @@ | ||
#endif | ||
|
||
#include <stdlib.h> | ||
+#include "err.h" | ||
#include "mem.h" | ||
|
||
void * |