Skip to content

Commit

Permalink
app-admin/terraform: new package
Browse files Browse the repository at this point in the history
Adding Hashicorp's terraform infrastructure as code utility. Information
on the tool can be found here: https://terraform.io and the code base
can be found here: https://github.com/hashicorp/terraform

Package-Manager: Portage-2.3.54, Repoman-2.3.12
Closes: https://bugs.gentoo.org/634538
Closes: gentoo#10740
Signed-off-by: Dan Molik <[email protected]>
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
dmolik authored and gyakovlev committed Jan 4, 2019
1 parent be5c4a9 commit 78b3d9a
Show file tree
Hide file tree
Showing 3 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/terraform/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST terraform-0.11.11.tar.gz 10938952 BLAKE2B 76062c2c95c95751f7a1a28fc7047ebd2255504dece99efa08ea8deede5e774a838571a2e0ab81fa90e2580823958d8e1781d154ecbed9c1d839a0cb2998487c SHA512 7c0cf4b0b70eab7dc88133d50ac4b586b72ac53e01c21c00766d03d10c753cfd404b146add21e378be8f1d305c5e92703cbaeac9e4c4b55bfc8b2532f74f63ee
28 changes: 28 additions & 0 deletions app-admin/terraform/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Dan Molik</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
Terraform is a tool for building, changing, and versioning infrastructure
safely and efficiently. Terraform can manage existing and popular service
providers as well as custom in-house solutions.

Terraform files describe the components needed to run a single application
or your entire datacenter. Terraform generates an execution plan describing
what it will do to reach the desired state, and then executes it to build
the described infrastructure. As the configuration changes, Terraform is
able to determine what changed and create incremental execution plans which
can be applied.
</longdescription>
<upstream>
<changelog>https://github.com/hashicorp/terraform/blob/master/CHANGELOG.md</changelog>
<remote-id type="github">hashicorp/terraform</remote-id>
</upstream>
</pkgmetadata>
28 changes: 28 additions & 0 deletions app-admin/terraform/terraform-0.11.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit golang-vcs-snapshot

DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
HOMEPAGE="https://www.terraform.io/"

EGO_PN="github.com/hashicorp/${PN}"
SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
DEPEND=">=dev-lang/go-1.11.0"

src_compile() {
cd "src/${EGO_PN}" || die
GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
-v -work -o "${S}/${PN}" ./ || die
}

src_install() {
dobin terraform
}

0 comments on commit 78b3d9a

Please sign in to comment.